Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

NetWorker: Log på NMC Mislykkes med meddelelsen "Der opstod en fejl under validering af brugerlegitimationsoplysninger"

Summary: Når du forsøger at logge på NMC (Network Management Console), vises følgende: Der opstod en fejl under validering af brugerlegitimationsoplysninger. Kontrollér, at NetWorker-godkendelsestjenesten kører. [Der opstod en fejl, fejl i et system API-opkald på lavt niveau Servermeddelelse: Sørg for, at serveren kører]. ELLER [Kunne ikke oprette forbindelse til NetWorker_ServerName:9090; Ingen fejl. Servermeddelelse: Sørg for, at serveren kører.] ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Følgende karakteriserer den adfærd, der observeres i forbindelse med dette problem:

  • Kan ikke logge på NMC efter genstart af NetWorker-serveren.
  • Når du forsøger at logge på NMC, vises der en fejlmeddelelse under valideringen af legitimationsoplysningerne.

 

Følgende meddelelser vises:

An error occurred while validating user credentials. Verify that Networker Authentication Service is running. [An error occurred, a low level system api call failure Server Message: Make sure that the server is running].

 

Eller

An error occurred while validating user credentials. Verify that Networker Authentication Service is running. [Failed to connect to NetWorker_ServerName:9090; No Error. Server Message : Make sure that the server is running.]

 

Dette kan løses midlertidigt ved at genstarte ALLE NetWorker-tjenester, men problemet dukker op igen ved næste genstart.

Problemet kan være periodisk.

Serveren er stadig ved at fuldføre handlingerne. Synlig i logfiler og via NetWorker-serveren nsrwatch Kommando.

 

Cause

Denne fejl kan opstå, hvis der er en portkonflikt for en af de porte, der bruges af AUTHC-tjenesten. Dette kan identificeres i NetWorker-serverens \nsr\logs\daemon.raw Log:

NetWorker_ServerName nsrctld NSR notice authservice: SEVERE: StandardServer.await: create[localhost:8009]:
NetWorker_ServerName nsrctld NSR notice authservice: java.net.BindException: Address already in use: JVM_Bind

 

Eller

NetWorker_ServerName nsrctld NSR notice authservice: SEVERE: StandardServer.await: create[localhost:8005]:
NetWorker_ServerName nsrctld NSR notice authservice: java.net.BindException: Address already in use: JVM_Bind

 

NetWorker: Sådan bruger du nsr_render_log

 

I dette tilfælde kan 8009- (Tomcat AJP-stikport) og 8005-porte (Tomcat Security Shutdown) ikke tildeles, da et andet program bruger dem. Dette kan forekomme, hvis der er et eller flere andre programmer installeret på denne server, som bruger Apache Tomcat. NetWorker-serveren (nsrd) styrer authservice og kan ikke bruges af brugeren. Følgende kan ses i daemon.raw:

NetWorker_ServerName nsrctld NSR notice Daemon authservice terminated.

 

Resolution

Mulighed 1:
Juster de porte, der bruges af den anden komponent, så der ikke er nogen portkonflikt med Apache Tomcat, der bruges af NetWorkers godkendelsestjeneste.

 

Mulighed 2:
Rediger de porte, der bruges af NetWorkers Tomcat-forekomst, ved at udføre følgende trin:

  1. Stop tjenesterne på NetWorker-serveren for at gøre følgende:
    Linux: nsr_shutdown
    Windows: net stop nsrexecd /y

  2. Identificer en port, der ikke bruges af nogen af de andre kørende tjenester:
    netstat -ab > netstat_ports.txt (f.eks.: 8089, 8087 osv. ...)

  3. Åbn filen server.xml under:
    Linux: /nsr/authc/conf/server.xml
    Windows: [NetWorker-installationssti]\nsr\authc-server\tomcat\conf

    Bemærk: NetWorker-installationsstien skal erstattes med den fulde sti til din NetWorker-installationsmappe.
  4. Rediger filen ved at erstatte port 8009 til 8089 (valgt i trin 2).
    For 8005-konflikt skal du ændre:
    <Server port="8005" shutdown="SHUTDOWN">
    TIL:
    <Server port="8085" shutdown="SHUTDOWN">

    For 8009-konflikt skal du ændre:
    <!-- Define an AJP 1.3 Connector on port 8009 --> <Connector port="8009" protocol="AJP/1.3" redirectPort="8443"/>
    TIL:
    <!-- Define an AJP 1.3 Connector on port 8089 --> <Connector port="8089" protocol="AJP/1.3" redirectPort="8443"/>

  5. Gem filen, og genstart NetWorker-serveren.

    BEMÆRK: Tjenesterne kan genstartes. Problemet bekræftes dog ikke som løst før næste genstart af operativsystemet:

    Linux: systemctl start networker
    Windows:
    net start nsrd
    net start gstd (Kun påkrævet, hvis NMC er installeret på NetWorker-serveren)

  6. Opret forbindelse til NMC.

 

Affected Products

NetWorker Management Console

Products

NetWorker, NetWorker Management Console
Article Properties
Article Number: 000072358
Article Type: Solution
Last Modified: 23 Feb 2024
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.