Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

NetWorker:NMCへのログインが「ユーザー資格情報の検証中にエラーが発生しました」で失敗する

Summary: NMC(ネットワーク管理コンソール)にログインしようとすると、次のように表示されます。ユーザー資格情報の検証中にエラーが発生しました。NetWorker認証サービスが実行されていることを確認します。[エラーが発生しました。低レベルのシステムAPIコールの失敗です。サーバー メッセージ: サーバーが実行されていることを確認してください。]または[NetWorker_ServerNameへの接続に失敗しました:9090;エラーはありません。サーバーメッセージ: サーバーが稼働していることを確認します。] ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

この問題で観察された動作の特徴は次のとおりです。

  • NetWorkerサーバーの再起動後にNMCにログインできない。
  • NMCにログインしようとすると、認証情報の検証中にエラーが表示されます。

 

次のメッセージが表示されます。

An error occurred while validating user credentials. Verify that Networker Authentication Service is running. [An error occurred, a low level system api call failure Server Message: Make sure that the server is running].

 

および/または

An error occurred while validating user credentials. Verify that Networker Authentication Service is running. [Failed to connect to NetWorker_ServerName:9090; No Error. Server Message : Make sure that the server is running.]

 

これは、すべてのNetWorkerサービスを再起動することで一時的に解決できますが、次回の再起動時に問題が再発します。

問題が断続的に発生する場合があります。

サーバーはまだ動作を完了中です。ログ内およびNetWorkerサーバーを介して表示可能 nsrwatch コマンドを使用できます。

 

Cause

このエラーは、AUTHCサービスで使用されるポートの1つにポートの競合がある場合に表示されることがあります。これは、NetWorkerサーバーの \nsr\logs\daemon.raw ログ:

NetWorker_ServerName nsrctld NSR notice authservice: SEVERE: StandardServer.await: create[localhost:8009]:
NetWorker_ServerName nsrctld NSR notice authservice: java.net.BindException: Address already in use: JVM_Bind

 

および/または

NetWorker_ServerName nsrctld NSR notice authservice: SEVERE: StandardServer.await: create[localhost:8005]:
NetWorker_ServerName nsrctld NSR notice authservice: java.net.BindException: Address already in use: JVM_Bind

 

NetWorker:nsr_render_logの使用方法(英語)」を参照してください。

 

この場合、8009(Tomcat AJPコネクター ポート)および8005(Tomcatセキュリティ シャットダウン)ポートは、別のアプリケーションが使用しているため割り当てることができません。これは、Apache Tomcatを使用する他のアプリケーションが1つ以上このサーバーにインストールされている場合に発生する可能性があります。認証サービスはNetWorkerサーバー(nsrd)によって制御され、ユーザーによる制御はできません。以下が daemon.raw:

NetWorker_ServerName nsrctld NSR notice Daemon authservice terminated.

 

Resolution

オプション1:
NetWorkerの認証サービスによって使用されるApache Tomcatと競合しないように、他のコンポーネントで使用されているポートを調整します。

 

オプション2:
次の手順を実行して、NetWorkerのTomcatインスタンスで使用されるポートを変更します。

  1. NetWorkerサーバー上のサービスを停止して、次の手順を実行します。
    Linuxの場合 nsr_shutdown
    Windowsの場合: net stop nsrexecd /y

  2. 実行中の他のサービスで使用されていないポートを特定します。
    netstat -ab > netstat_ports.txt (例: 8089、8087など...)

  3. 次の場所で server.xml ファイルを開きます。
    Linuxの場合/nsr/authc/conf/server.xml
    Windows:[NetWorkerインストール パス]\nsr\authc-server\tomcat\conf

    注:NetWorkerのインストール パスは、NetWorkerインストール ディレクトリのフル パスに置き換えられます。
  4. ポート8009を(手順2で選択)8089に置き換えてファイルを変更します。
    8005競合の場合は、次のように変更します。
    <Server port="8005" shutdown="SHUTDOWN">
    宛先:
    <Server port="8085" shutdown="SHUTDOWN">

    8009競合の場合は、次のように変更します。
    <!-- Define an AJP 1.3 Connector on port 8009 --> <Connector port="8009" protocol="AJP/1.3" redirectPort="8443"/>
    宛先:
    <!-- Define an AJP 1.3 Connector on port 8089 --> <Connector port="8089" protocol="AJP/1.3" redirectPort="8443"/>

  5. ファイルを保存し、NetWorkerサーバーを再起動します。

    メモ: サービスを再起動できます。ただし、この問題は、次回のOSの再起動まで解決済みとして確認されません。

    Linuxの場合 systemctl start networker
    Windowsの場合:
    net start nsrd
    net start gstd (NMCがNetWorkerサーバーにインストールされている場合にのみ必要)

  6. NMCに接続します。

 

Affected Products

NetWorker Management Console

Products

NetWorker, NetWorker Management Console
Article Properties
Article Number: 000072358
Article Type: Solution
Last Modified: 23 Feb 2024
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.