Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

NetWorker: Aanmelden bij NMC mislukt met "Er is een fout opgetreden tijdens het valideren van gebruikersreferenties"

Summary: Wanneer u zich probeert aan te melden bij de Network Management Console (NMC), ziet u het volgende: Er is een fout opgetreden tijdens het valideren van gebruikersreferenties. Controleer of de NetWorker Authentication Service wordt uitgevoerd. [Er is een fout opgetreden, een systeem-API-aanroepfout op laag niveau Serverbericht: Zorg ervoor dat de server actief is]. OF [Kan geen verbinding maken met NetWorker_ServerName:9090; Geen fout. Server Bericht : Controleer of de server actief is.] ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Het volgende kenmerkt het gedrag dat bij dit probleem wordt waargenomen:

  • Kan niet aanmelden bij NMC na het opnieuw opstarten van de NetWorker-server.
  • Wanneer u zich probeert aan te melden bij de NMC, ontvangt u een foutmelding tijdens het valideren van referenties.

 

De volgende berichten worden weergegeven:

An error occurred while validating user credentials. Verify that Networker Authentication Service is running. [An error occurred, a low level system api call failure Server Message: Make sure that the server is running].

 

Of

An error occurred while validating user credentials. Verify that Networker Authentication Service is running. [Failed to connect to NetWorker_ServerName:9090; No Error. Server Message : Make sure that the server is running.]

 

Dit kan tijdelijk worden opgelost door ALLE NetWorker-services opnieuw op te starten, maar het probleem verschijnt opnieuw bij de volgende keer opstarten.

Probleem kan af en toe optreden.

De server is nog steeds bezig met het voltooien van bewerkingen. Zichtbaar in logboeken en via de NetWorker-server nsrwatch Opdracht.

 

Cause

Deze fout kan optreden als er een poortconflict is voor een van de poorten die door de AUTHC-service worden gebruikt. Dit is herkenbaar in het \nsr\logs\daemon.raw Log:

NetWorker_ServerName nsrctld NSR notice authservice: SEVERE: StandardServer.await: create[localhost:8009]:
NetWorker_ServerName nsrctld NSR notice authservice: java.net.BindException: Address already in use: JVM_Bind

 

Of

NetWorker_ServerName nsrctld NSR notice authservice: SEVERE: StandardServer.await: create[localhost:8005]:
NetWorker_ServerName nsrctld NSR notice authservice: java.net.BindException: Address already in use: JVM_Bind

 

NetWorker: Hoe nsr_render_log te gebruiken

 

In dit geval kunnen de poorten 8009 (Tomcat AJP-connectorpoort) en 8005 (Tomcat Security Shutdown) niet worden toegewezen omdat ze door een andere toepassing worden gebruikt. Dit kan gebeuren als er een of meer andere applicaties op deze server zijn geïnstalleerd die gebruikmaken van Apache Tomcat. De NetWorker-server (nsrd) beheert de authservice en kan niet door de gebruiker worden beheerd. Het volgende is te zien in de daemon.raw:

NetWorker_ServerName nsrctld NSR notice Daemon authservice terminated.

 

Resolution

Optie 1:
Pas de poorten aan die door de andere component worden gebruikt, zodat er geen poortconflict is met Apache Tomcat dat wordt gebruikt door de verificatieservice van NetWorker.

 

Optie 2:
Wijzig de poorten die worden gebruikt door de Tomcat-instantie van NetWorker door de volgende stappen uit te voeren:

  1. Als u de services op de NetWorker-server stopt, gaat u als volgt te werk:
    Linux: nsr_shutdown
    Windows: net stop nsrexecd /y

  2. Identificeer een poort die niet wordt gebruikt door een van de andere actieve services:
    netstat -ab > netstat_ports.txt (bijvoorbeeld: 8089, 8087, enzovoort...)

  3. Open het server.xml bestand onder:
    Linux: /nsr/authc/conf/server.xml
    Windows: [NetWorker installatiepad]\nsr\authc-server\tomcat\conf

    Opmerking: Het installatiepad van NetWorker moet worden vervangen door het volledige pad van uw NetWorker-installatiemap.
  4. Wijzig het bestand door poort 8009 te vervangen door 8089 (gekozen in stap 2).
    Wijzig voor 8005-conflict:
    <Server port="8005" shutdown="SHUTDOWN">
    AAN:
    <Server port="8085" shutdown="SHUTDOWN">

    Wijzig voor 8009-conflict:
    <!-- Define an AJP 1.3 Connector on port 8009 --> <Connector port="8009" protocol="AJP/1.3" redirectPort="8443"/>
    AAN:
    <!-- Define an AJP 1.3 Connector on port 8089 --> <Connector port="8089" protocol="AJP/1.3" redirectPort="8443"/>

  5. Sla het bestand op en start de NetWorker-server opnieuw op.

    OPMERKING: Services kunnen opnieuw worden gestart; Het probleem wordt echter pas als opgelost bevestigd wanneer het besturingssysteem de volgende keer opnieuw wordt opgestart:

    Linux: systemctl start networker
    Windows:
    net start nsrd
    net start gstd (Alleen vereist als NMC is geïnstalleerd op de NetWorker-server)

  6. Maak verbinding met de NMC.

 

Affected Products

NetWorker Management Console

Products

NetWorker, NetWorker Management Console
Article Properties
Article Number: 000072358
Article Type: Solution
Last Modified: 23 Feb 2024
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.