Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

Сбой резервного копирования образа VM в Avamar с ошибкой: vSphere Task failed: «Unable to access file since it is locked».

Summary: Проблема обычно возникает, когда прокси-серверу не удается отменить монтирование дисков после успешного резервного копирования, что приводит к проблеме блокировки.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



В журналах отображается следующая ошибка:
2020-01-27 09:31:25 avvcbimage Info <14631>: VM Disk Consolidation for '[Avamar_Prod_ClusterA_avamar] avamar03/avamar.vmx' task still in progress, sleep for 3 sec 2020-01-27 09:31:28 avvcbimage Error <16006>: vSphere Task failed: 'Unable to access file  since it is locked'. 2020-01-27 09:31:28 avvcbimage Error <14635>: VM Disk Consolidation for '[Avamar_Prod_ClusterA_avamar] avamar03/avamar03.vmx' task creation encountered a problem 2020-01-27 09:31:28 avvcbimage Info <40733>: VM Disk consolidation is not complete, moref 'vm-123456'. 2020-01-27 09:31:28 avvcbimage Warning <40644>: VM needs consolidation failed 
 

Cause

Проблема обычно возникает, когда прокси-серверу не удается отменить монтирование дисков после успешного резервного копирования, что приводит к проблеме блокировки.

Resolution

Выполните следующие действия для устранения проблемы:

1) Убедитесь, что резервное копирование не выполняется, и выполните следующие команды на узле Avamar с помощью Putty:

java -jar proxycp.jar --listsnapshots --cleanup
java -jar proxycp.jar --listproxydisk - cleanup
java -jar proxycp.jar --consolidatesnapshots --vm <REPLACEWITHVMNAME>

Если описанные выше действия не сработали:

2) Выполните консолидацию вручную с помощью веб-клиента vSphere.

Если это не сработает и не удается выполнить консолидацию:

3) Обратитесь за помощью к администратору VMware и укажите следующую статью:
https://kb.vmware.com/s/article/2107795

Affected Products

Avamar

Products

Avamar
Article Properties
Article Number: 000069304
Article Type: Solution
Last Modified: 16 Oct 2021
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.