Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

Dell VxRail: Failure During Preupgrade to 4.0 and Later

Summary: VxRail may have a failure during a preupgrade to 4.0 or later. There are multiple scenarios below for a resolution.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

There are multiple scenarios that result in this issue. See the Resolution section for possible issues and corresponding remediation.

Cause

The internal service errors for the offline upload operation failure may be due to one of the following scenarios in the Resolution section.   

Resolution

  • Issue #1: There is not enough space for the unpacked composite bundle (required 2.35 * compositeBundleSize).
Possible solution: Try to clean up the file system (delete temp files and any other unused files) on the VxRail Manager virtual machine to get to the required space 2.35 * compositeBundleSize. 
NOTE: If the upgrade starts from certain code levels, there is a manual process that is required to expand the disk partition on VxRail Manager before upgrade. Contact Dell Support for further assistance.
  • Issue #2: ESXi hardware platform is not compatible with ESXi upgrade bundle which in the composite bundle.
Possible solution: The existing hardware platform is not compatible with the used upgrade bundle. This is because the ESXi hardware vendor info does not match with the ESXi upgrade bundle in the composite bundle. To resolve this issue, ensure to obtain the download bundle that matches with your ESXi hardware vendor info from Dell download site or ACG category. 
  • Issue #3: vCenter version is not compatible with ESXi upgrade bundle which in the composite bundle.
Possible solution: The target ESXi version should be compatible with the installed vCenter version. This usually happens in external VC context. It means that the VC version falls behind. To resolve this, upgrade your external VC with the version that matches the included ESXi version. 
  • Issue #4: ESXi hardware platform is not compatible with VIB upgrade bundle which in the composite bundle.
Possible solution: The target VIB version should be compatible with the installed ESXi platform version. This is because the included VIB bundle does not matches with the ESXi hardware vendor info. To resolve this issue, ensure to obtain the download bundle that matches with your ESXi hardware vendor info from Dell download site or ACG category. 
  • Issue #5: There is an error while reading the uploaded upgrade bundle from the Tomcat temp storage.
Possible solution: Try to clean up the file system (delete temp files and any other unused files) on the VxRail Manager virtual machine and restart the service. Contact customer service if the issue is not resolved after.
  • Issue #6: Failed to obtain current ESXi version of host.
Possible solution: Usually it is caused by the loss of host connection with VC. Verify that the host connection is fine between VC and the host.
  • Issue #7: Failed to obtain current VxRail VIB version of host
Possible solution: Usually it is caused by the loss of host connection with VC, or VxRail VIB is missing from the host. Verify that the host connection is fine between VC and the host or VxRail VIB gets installed.
  • Issue #8: Platform Service is not installed or ready yet
Possible solution: There can be many causes that result in platform service error. Contact customer service when this issue occurs.
  • Issue #9: Quanta platform is not supported to upgrade to 7.x.
Possible solution: None
  • Issue #10: The upgrade bundle's integrity verification is failed.

Possible solution 1: When the error message contains "Precheck failure: Failed to verify certificate chain." Or "Precheck failure: Failed to verify the manifest file's signature.", download a new upgrade bundle and retry upgrade. 
Possible solution 2: When the error message contains "Precheck failure: Failed to verify the manifest file.", if it is using public API v5 to upgrade, and the upgrade bundle is customized (VxRail only supports removing unnecessary upgrade components from upgrade bundle, does not support adding or modifying upgrade components), see the latest VxRail API User Guide to check the new parameter usage for v5 API. Otherwise, download a new upgrade bundle and retry upgrade.

  • Issue #11: TPM1.2 is enabled on the 14G VxRail cluster (version 4.7.x or 7.0.x) so the upgrade to VxRail 8.0.000 will be blocked. 

Possible solution: See Article 000204703 for options.

  • Issue #12: The upgrade bundle is for Dell VxRail 14G and later platforms. You cannot install it on 13G platforms. 

Possible solution: VxRail 7.0.411 is the last recommended VxRail 7.0.x release for these Dell VxRail 13G systems to upgrade to. You will not be able to upgrade to a later release if you have a 13G node in your cluster. 

  • Issue #13: Upload bundle failed when LCM from 4.7.212 or earlier versions directly to 7.0.480. 

Possible solution: If current cluster version is lower than 4.7.300, it is not supported to directly upgrade to 7.0.480. Check 7.0.480 release notes for supported direct upgrade path, and upgrade the cluster to any of the supported versions first (e.g 4.7.300), then proceed to upgrade to 7.0.480.

  • Issue #14: Failed to upload bundle. The error message showed "Failed to update the VxRail Radar utility because /mystic/radar owership is not tcserver."

Possible solution: Login VxRail manager via ssh and execute command: su chown -R tcserver:pivotal /mystic/radar

 

Affected Products

VxRail Software

Products

VxRail 460 and 470 Nodes, VxRail Appliance Family, VxRail Appliance Series
Article Properties
Article Number: 000062924
Article Type: Solution
Last Modified: 15 Aug 2024
Version:  11
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.