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NVP vProxy: VM Backup fails with "snapshot has already been deleted or has not been completely created"

Summary: VM Backup fails with "snapshot has already been deleted or has not been completely created"

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Symptoms

  • VM backups performed with the NVP vProxy appliance report the following error:
YYYY-MM-DDTHH:mm:SSZ ERROR: Request to remove snapshot 'snapshot-#####' on VM 'VM_NAME' was rejected by vCenter 'VCENTER_NAME': ServerFaultCode: The object 'vim.vm.Snapshot:snapshot-#####' has already been deleted or has not been completely created

Cause

There were old snapshot files in the datastore for this VM.

Resolution

The ProxyHC utility can be used to clean up left over disks and snapshots. 

To perform manual cleanup in VMware, perform the following:
  1. Log into the vSphere web client.
  2. Right-click the VM and select Snapshots->Delete All Snapshots.
  3. Right-click the VM and select Snapshots->Consolidate.
  4. Select the Datastores tab and browse to the directory for the VM, check for any snapshot files. If any snapshot files reside here, delete them.
  5. If no snapshots are found but the issue persists attempt to create a snapshot from VMware.
NOTE:If the VM is performing app-consistent backups (MSVMAPPAGENT) perform a quiesced snapshot; otherwise, perform a non-quiesced snapshot.
  1. Repeat steps 2-4 to ensure the snapshot files are removed.
  2. Run a backup.

At the start of VM backups the vProxy requests the vCenter create a snapshot for the VM, a request is sent at the end of the backup to remove the snapshot. The vCenter server creates, manages, deletes the snapshot files. If this issue persists or an error is encountered during any of the above steps please contact VMware support for assistance.

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000172495
Article Type: Solution
Last Modified: 27 Sept 2023
Version:  3
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