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Thunderbolt Docking Stations Not Initializing at the Login Screen When on a Domain

Summary: This article gives information about the Dell Thunderbolt Docking Stations not initializing at the login screen when used on a Domain.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Peripherals like a keyboard and mouse connected using USB to a Thunderbolt Dock may work in BIOS, do not work at the login screen, but work after login.

Affected Platforms:

  • Dell Thunderbolt Dock TB15
  • Dell Thunderbolt Dock TB16
  • Dell Precision Dual USB-C Thunderbolt Dock - TB18DC
  • Dell Thunderbolt Dock - WD19TB
  • Dell Thunderbolt Dock - WD19TBS

Cause

Thunderbolt interface architecture up to Thunderbolt 3.

Resolution

Kernel Direct Memory Access (DMA) Protection

The new Kernel DMA Protection that is active in Windows does not let Thunderbolt docking stations initialize before booting into the Operating System (OS). This is working as designed.

Companies or individuals using a Domain login to push group policies may see this issue. This is due to group policies not being pushed to the computer before the User logs in.


Group Policy Change

To fix this behavior, the group policy must be changed to allow the docking station to initialize at the login screen.

Additional Information:


An example of the settings in Intune:
Intune Settings Example

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Affected Products

Dell Thunderbolt Dock TB15, Dell Thunderbolt Dock TB16, Dell Precision Dual USB-C Thunderbolt Dock - TB18DC, Dell Thunderbolt Dock - WD19TB, Dell Thunderbolt Dock – WD19TBS
Article Properties
Article Number: 000134656
Article Type: Solution
Last Modified: 16 Oct 2024
Version:  7
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