Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products
Some article numbers may have changed. If this isn't what you're looking for, try searching all articles. Search articles

Google Chrome Browser Not Working in Windows 10 After a Windows Upgrade

Summary: Steps for getting Google Chrome to work with Windows 10 after Windows has been upgraded from a pervious version.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The Google Chrome browser will not open or work correctly.

Cause

No cause information.

Resolution

Google Chrome Browser

If you are having issues with the Google Chrome browser after you upgrade to Windows 10 (from Windows 7, 8, or 8.1).

Try the steps listed in the following link: Google Chrome Common Fixes This hyperlink is taking you to a website outside of Dell Technologies.


Possible Workaround:

If the Google Chrome browser can still open, type Chrome://flags into the Google Chrome browser address bar (Figure 1) and change the "Enable Touch Events" setting from "Automatic" to "Enabled" (Figure 2).
Google Chrome Browser Tabs
(Figure 1)

Google Chrome Browser Enable Touch Events
(Figure 2)

Back to Top

Affected Products

Alienware, Inspiron, Legacy Desktop Models, OptiPlex, Vostro, XPS, G Series, Chromebook, G Series, Alienware, Inspiron, Latitude, Vostro, XPS, Legacy Laptop Models, Fixed Workstations, Mobile Workstations
Article Properties
Article Number: 000075716
Article Type: Solution
Last Modified: 14 Nov 2023
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.