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PPDM After upgrade of PPDM appliance to 19.10 version or higher, Support Assist configuration using Gateway stops working

Summary: After upgrade of PPDM appliance to 19.10 version or higher, Support Assist configuration using Gateway stops working

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Customer might experience a problem after upgrade of PPDM appliance to 19.10 version or above when using ESRS Gateway.

Following error can be seen on ESE log located under /var/log/ese folder on PPDM appliance:
 
7 2022-07-26 12:27:52,067 CP Server Thread-8 DEBUG urllib3.connectionpool LN: 433 https://gateway_name:9443 "PUT /esrs/v2/devices/PowerProtectDataManager/ELMPPD09207Q9F/deviceKey HTTP/1.1" 401 None 7 2022-07-26 12:27:52,142 CP Server Thread-8 INFO DellESE.ese.srs.srswebapi LN: 264 Calls universal device key api Status: 401 - Unauthorized

Cause

Previous version of PPDM 19.9 and older versions  uses older version of ESE which is supported by legacy ESRS gateway which is ESRS Gen 3.

However, starting with PPDM 19.10 version, PPDM uses an upgraded version of ESE which is Gen 4. 

When ESE tried to do a Gen 4 request for a new license key it failed because the Gen 3 ESRS gateway didn’t understand and rejected with HTTP 401 Unauthorized.

This is documented:

image.png

And also reported during precheck list prior to upgrade as follows:

image.png

Resolution

Customer can either upgrade existing ESRS Gateway to a SCG Gen 4 version.

Alternatively, instead of upgrading existing ESRS Gateway which might affect other products using the same, customer can deploy a new SCG Gateway with different name and IP, and configure PPDM to use this newly deployed SCG Gateway.

Contact Dell Support for assistance.
Article Properties
Article Number: 000202217
Article Type: Solution
Last Modified: 15 Dec 2022
Version:  3
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