Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products

No Display on Random Monitors after Resume from Modern Standby with Extended Display Mode

Summary: This article provides the step to troubleshoot when no display is shown on random monitors after resume from Modern Standby with Extended Display Mode.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Users may notice one of the following symptoms:

  1. Both internal and external monitor would have no display after resume from Modern Standby.
  2. External monitor would have no display after resume from Modern Standby.

This issue occurs only when the computer resume from Modern Standby with dGPU Mode was set or enabled under the system BIOS.

Cause

The timing to notify graphic driver issue after entering the Modern Standby mode.

Resolution

Updating the latest BIOS version on the computer will help resolve the issue. To download and install the latest BIOS:

WARNING: Dell recommends disconnecting devices such as external hard drives, printers, scanners, and so on before updating the BIOS.
WARNING: Dell laptops must have the battery installed and charged to at least 10% before you begin the BIOS update. Dell recommends connecting the laptop to AC power before proceeding with the update process.
NOTE: To learn more about updating the BIOS on a Dell computer, see the Dell knowledge base article Dell BIOS Updates.
NOTE: To install the BIOS, your user account must have administrator privileges.
  1. Browse to https://www.dell.com/support/drivers.
  2. Identify your Dell computer.
    1. Click Download & Install SupportAssist to auto-detect your Dell computer. Follow the on-screen instructions to install Dell SupportAssist. For more information, see the Dell knowledge base article Dell SupportAssist (formerly Dell System Detect): Overview and Common Questions.
    2. Enter the Service Tag of the laptop and click Search.
    3. Or, click Browse all products and select your Dell computer from the catalog.
  3. Select the Operating System that is installed on the Dell computer.
  4. Under Category, select BIOS.
  5. Locate the latest System BIOS.
  6. Click Download and save the file to your computer.
  7. Open File Explorer and browse to the location where the downloaded file is saved.
  8. Double-click the BIOS setup file and follow the on-screen instructions to complete the installation process.

Affected Products

Alienware x15 R1, Alienware x17 R1
Article Properties
Article Number: 000188292
Article Type: Solution
Last Modified: 25 Aug 2021
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.