Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
Some article numbers may have changed. If this isn't what you're looking for, try searching all articles. Search articles

Resolving Error 503 Service Unavailable Failed to connect to endpoint in VMware vCenter

Summary: Troubleshooting steps to resolve the error 503, "Service Unavailable Failed to connect to endpoint" with VMware vCenter. Error 503 can be caused by various scenarios. The solutions for two common scenarios are documented. ...

This article applies to   This article does not apply to 

Symptoms

Administrators may be unable to access the vCenter. They may find that the vpxd and inventory service failed to start.

Error message: 503 Service Unavailable Failed to connect to endpoint: [N7Vmacore4Http20NamedPipeServiceSpecE:0x00007f975808ee30] _serverNamespace = / action = Allow _pipeName =/var/run/vmware/vpxd-webserver-pipe)

Cause

There can be various causes for this error. Below are two possible scenarios:

Scenario 1

Periodically, the password used by the machine's account is automatically refreshed.

This password is stored on the Machine Account on vCenter Server and within the VMware Directory Service residing on the Platform Services Controllers. If the backup used to perform a restore predates the most recent password refresh, upon restore, the Machine Account is unable to log in to the VMware Directory Service.

Also, if the vCenter Server is rolled back to a snapshot state which predates the most recent password refresh, upon restore, the Machine Account is unable to log in to the VMware Directory Service.
 


Scenario 2

An ISO is mounted to any number of VMs from within vCenter UI, with lengthy names when using the Content Library on VSAN Datastores. This makes it too long for the database.

In the /var/log/vmware/vpxd.log file, one of the last lines reads string too large or string too large for database.

Resolution

Scenario 1

For vCenter Server Appliance:

  1. Log in to the vCenter Server using SSH as the root user.
  2. Run the shell command to switch to BASH.
  3. Run the following command to reset the password:
    /usr/lib/vmware-vmafd/bin/dir-cli computer password-reset --login administrator --live-dc-hostname <Platform Services Controller FQDN> --password <administrator@vsphere.local password>

    For example:
    /usr/lib/vmware-vmafd/bin/dir-cli computer password-reset --login administrator --live-dc-hostname mgmt01psc01.sfo01.rainpole.local --password 'VMware1!'

    A successful password reset outputs:
    Password for machine account reset.
  4. Run the following commands to start the vCenter Server services:
    service-control --stop --all
    service-control --start --all


Scenario 2

Follow VMware KB article Cannot connect host to vCenter due to error: string too large for database (55610)This hyperlink is taking you to a website outside of Dell Technologies..

This KB article references the Host but has familiar impact on the vCenter Server.

In case neither scenario applies, use this VMware KB article for additional troubleshooting: "503 Service Unavailable" error on the vSphere Web Client when logging in or accessing the vCenter Server (67818)This hyperlink is taking you to a website outside of Dell Technologies..

Additional Information

Affected Products

VxRail, VxRail Appliance Family