Start a Conversation

This post is more than 5 years old

Solved!

Go to Solution

66538

March 28th, 2012 15:00

vlan routing to internet

Hi guys.

I am not a network guy but I am trying to learn. I have a layer 3 power-connect switch. What I am trying to do is have three vlans with inter vlan routing enabled, and then routing enabled globally, two vlans will have computers attached to them, the third one will connect to my router and will use the routers address as the default gateway on the switch.

Heres my config, sorry I don't have access to the switch right now so this is not the exact config,

vlan 5 (192.168.1.2 255.255.255.0) port 1/g5 switch port mode general, switchport general allowed vlan add 5, switchport general pvid 5

vlan 10 (192.150.3.1 255.255.255.0) port 1/g13 switch port mode general, switchport general allowed vlan add 10, switchport general pvid 10

vlan 20(192.150.4.1 255.255.255.0) port 1/g14 switch port mode general, switchport general allowed vlan add 20, switchport general pvid 20

ip route 0.0.0.0 0.0.0.0 255.255.255.0 192.168.1.1  (this is the routers address)

Routing is enabled globally along with the vlans.

I can get pcs on the two vlans(10 &20) to talk to each other. I can also ping the routers IP from the switch but I can't ping the routers IP from the pcs attached to the two vlans or get inetner on the pcs. I dunno what I am missing. I am not even sure if its possible. 

Another thing I have noticed is even though I can ping the routers address from the switch I can't ping any internet address. I have also added two static routes on the router to point to the two vlan IPs.

static route 192.150.3.0 255.255.255.0 192.150.3.1 

static route 192.150.4.0 255.255.255.0 192.150.4.1 

Thanks in advance.

V.

12 Posts

April 4th, 2012 14:00

Hi all,

I formatted the file system on the dell switch, flashed the latest firmware and re-did the whole setup. Now its working flawless! I have disabled RIP on the switch and on the wireless bridge. I think the switch was unstable. Thank you all for the inputs.

Next thing I want to do is to serve DHCP from a VLAN. I will add five ports to a new vlan and the have the VLAN run the DHCP. Is it even possible? Is the switch capable of running DHCP or do I have to relay to an actual DHCP server running in a Windows/Linux box?

802 Posts

March 28th, 2012 16:00

First thing we want to check is on the PC’s do you have the default gateway of 192.150.3.1 on the PC connected to port 1/g13 and then 192.168.150.4.1 vlan 10 on the PC connected to 1/g14 vlan 20?

Typically you would set those same ports as an access port when connecting to a client.

console# configure

console(config)# interface ethernet xxx

console(config-if)# switchport mode access

console(config-if)# switchport access vlan xxx

console(config-if)# end

Then on vlan 5 you would set up trunk mode to allow all needed vlan to traverse the link.  This is depending on the compatiblity of the router connected on the other end.  You may have to stick with the general mode that can be a better fit with 3rd party devices.

Either way you will need to allow the other vlans on the interface.  Whether it is trunk or general something like the example below.

console# configure

console(config)# interface ethernet xxx

console(config-if)# switchport mode trunk

console(config-if)# switchport trunk allowed vlan add 10,20

Do you have a default gateway set on the switch globally pointing to the 192.168.1.1 router?

If you are not able to ping a internet address from the switch then you may need additional configuration on the router side to allow traffic to return.

I hope this helps,

Keep us updated

12 Posts

March 28th, 2012 17:00

Willy,

Thanks for the prompt response. Yes, the PCs have their respective default gateways set. And the router is just a netgear wireless router(home grade). I have not setup trunking on 1/g5 becuz the router does not understand Layer2 but I will try that out.

12 Posts

March 28th, 2012 20:00

This is what my config looks like.

!Current Configuration:
!System Description "Powerconnect 6248, 3.2.1.3, VxWorks 6.5"
!System Software Version 3.2.1.3
!Cut-through mode is configured as disabled
!
configure

vlan database

vlan 5,10,20

vlan routing 10 1

vlan routing 20 2

vlan routing 5 3

exit

stack

member 1 2

exit

ip address none

ip name-server 192.168.1.1

ip routing

ip route 0.0.0.0 0.0.0.0 192.168.1.1

interface vlan 5

routing

ip address 192.168.1.2 255.255.255.0

ip rip

exit

interface vlan 10

routing

ip address 192.150.3.1 255.255.255.0

ip rip

exit

interface vlan 20

routing

ip address 192.150.4.1 255.255.255.0

ip rip

exit

username "admin" password xxxxxxxx level 15 encrypted

!

interface ethernet 1/g5

switchport mode general

switchport general pvid 5

switchport general allowed vlan add 5,10,20

exit

!

interface ethernet 1/g13

switchport mode general

switchport general pvid 10

switchport general allowed vlan add 10

exit

!

interface ethernet 1/g14

switchport mode general

switchport general pvid 20

switchport general allowed vlan add 20

exit

exit

12 Posts

March 28th, 2012 20:00

Hi,

I made a little progress. I enabled RIP on the router now I am able to ping the router from the PCs but still cannot connect to the internet. And its not a DNS issue. Any idea?

12 Posts

March 29th, 2012 01:00

I removed the static routes from the router, enabled dynamic routing with RIP. Now I am able to connect to the internet from the switch. But still unable to from the PC. I can ping the router from the PC. I dunno whats happening. But this is what I see in the switches routing table.

Total Number of Routes 5

Network Address Subnet Mask Protocol Next Hop Interface Next Hop IP Address

0.0.0.0 0.0.0.0 Default vlan5 192.168.1.1

192.150.3.0 255.255.255.0 Local vlan10 192.150.3.1

192.150.4.0 255.255.255.0 Local vlan20 192.150.4.1

192.168.0.0 255.255.255.0 RIP        vlan5 192.168.1.1

192.168.1.0 255.255.255.0 Local vlan5 192.168.1.2

Any input is appreciated.

V.

12 Posts

March 29th, 2012 01:00

And this is what in routers routing table.

Current Routing Table

Destination LAN IP Subnet Mask Default Gateway

192.168.1.0 255.255.255.0 0.0.0.0

192.168.0.0 255.255.255.0 0.0.0.0

192.150.3.0 255.255.255.0 192.168.1.2

192.150.4.0 255.255.255.0 192.168.1.2

0.0.0.0 0.0.0.0 192.168.0.1

802 Posts

March 29th, 2012 11:00

The only thing on the Dell switch that I can think of is to set ports 1/g13, 1/g14 to switchport access instead of the general mode that you have.  If you can reach the router from the PC and the switch can reach the internet then the routing is missing a step.  Have you power cycled both devices since you have made the latest changes?  I have even started over with RIP and then put the same networks back in and it suddenly started working.

12 Posts

March 29th, 2012 12:00

Yes, I have started both the routers and the switches. I am going to work on it further later in the evening. So, if the switch can connect to the internet fine, the PCs should theoretically be able to connect right? I think changing those two ports to "access" might solve my problem. Thanks,

12 Posts

March 31st, 2012 14:00

Changing the port to access mode did not help either. I have done everything I could. The switch can access the internet fine but not the PC.

27 Posts

April 1st, 2012 10:00

I have similar setup in my 6248.  Three VLANs.  

10.0.0.0/24  - vlan1 interface ip -> 10.0.0.1

10.0.1.0/24  - vlan2 interface ip -> 10.0.1.1

10.0.2.0/24  - vlan3 interface ip -> 10.0.2.1

Routing is enabled globally.  

0.0.0.0. 0.0.0.0  255.255.255.0 10.0.2.2

So the edge router is at 10.0.2.2  

On the router, I have this route statements:

10.0.0.0 255.255.255.0  10.0.2.1

10.0.0.1 255.255.255.0  10.0.2.1

I have no problem whatsoever with this setup.  

You should never have RIP for this setup at all.  RIP adds more overhead and chatty. 

BTW, I don't think I configured a PVID for my VLANs.  Can someone tell me why would I need the PVID?  Otherwise, the routing works flawlessly. 

Thanks

12 Posts

April 1st, 2012 21:00

Hi,

I did get it to work. I added another netgear router before the layer 3 powerconnect and now its working flawless. Its working but I want to find out why it was not working in the first place. Anywho, RIP is still enabled in the wireless bridge and in the dell switch. Now I will disable RIP one after another and see how it goes.

802 Posts

April 2nd, 2012 16:00

If you are not wanting RIP on the switch you can basically copy the routing table and then enter it manually.

Keep us updated.

12 Posts

April 2nd, 2012 18:00

sorry the dell switch is layer 3 not layer 2 :D

802 Posts

April 2nd, 2012 18:00

If the connectivity works with RIP on and then not when RIP is turned off.  I would suggest running a “show ip route” command with RIP on and then off and compare the routes you have.  I suspect you have a missing route somewhere.  

Example:

console# show ip route

Route Codes: R - RIP Derived, O - OSPF Derived, C - Connected, S - Static

      B - BGP Derived, IA - OSPF Inter Area

      E1 - OSPF External Type 1, E2 - OSPF External Type 2

      N1 - OSPF NSSA External Type 1, N2 - OSPF NSSA External Type 2

C      10.0.0.0/24 [0/0] directly connected,   vlan 10

S      11.0.0.0/24 [1/0] via 10.0.0.5,   vlan 10

No Events found!

Top