症狀
1.1.5より前のバージョンのKioxia CD5 7.68TB NVMe SSDファームウェアで、ドライブの早期故障を引き起こす可能性のある問題が特定されています。ノードがOneFS 9.1.0.4以前を実行している場合、この障害モードによってノードがパニック状態になり再起動し、システム ログに次のようなカーネル パニック メッセージが記録されることがあります。
panic @ time 1606735946.256, thread 0xfffff802cab45000: bio 0xfffff802cb64e060 cmd 1<BIO_READ> stuck in iosched nvd2 for over 240 seconds (240 seconds, cycle 40752ea883a294, arr 4074b401850eac), total_inprog 4, bio_rd_inprog 0, bio_wr_inprog 4, bio_rd_inqueue 1, bio_wr_inqueue 0
原因
ドライブの製造元は、このドライブの出荷時ファームウェアで、ドライブの早期故障につながる可能性がある問題を特定しました。DellEMC PowerScaleエンジニアリングは、正常に処理されずにカーネル パニックを引き起こすこの障害モードの原因となるOneFSコードの問題を特定しました。
解析度
これらのドライブの早期故障を引き起こすドライブ ファームウェアの問題を解決するには、最新のドライブ サポート パッケージ(1.37.2以降)をインストールし、ドライブ ファームウェア アップデートを実行して、ドライブをファームウェア バージョン1.1.5以降にアップデートします。ドライブ ファームウェア プロセスは無停止で処理され、メンテナンス ウィンドウをスケジュールせずに実行できます。新しいドライブ サポート パッケージ(DSP)をインストールし、クラスター上のドライブ ファームウェアをアップデートする手順については、DSPリリースに付属するリリース ノートを参照してください。
OneFSバージョン9.1.0.4以前の特定のドライブ障害シナリオでPowerScaleノードがパニックを起こす原因となるOneFSの問題を解決するには、最新のOneFSロールアップ パッチ(バージョン9.1.0.6以降)をインストールするか、OneFS 9.2以降にアップグレードします。インストール手順については、最新のロールアップ パッチ(RUP)またはOneFSリリースに付属するリリース ノートを参照してください。
受影響的產品
PowerScale F600