Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

Dell-kannettavan yleisten muistiongelmien diagnosointi ja ratkaiseminen

Résumé: Seuraavassa artikkelissa on tietoja Dellin kannettavissa ilmenevistä muistiongelmista ja niiden vianmäärityksestä.

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Cause

Syytiedot eivät ole käytettävissä.

Résolution

Kannettavan tietokoneen muistin vianmääritys

Tässä artikkelissa on tietoja Dellin kannettavien tietokoneiden muistiongelmista sekä muistiongelmien vianmäärityksestä ja ratkaisemisesta. Muistin vianmääritys jakautuu tavallisesti kolmeen osaan:

  • Diagnostics
  • Laitteisto
  • Ohjelmistot

Yleisiä muistiongelmia saatat havaita.

  • Käynnistysongelmat, joissa on muistivirhekoodeja
  • Järjestelmä ei käynnisty muistivian vuoksi
  • Järjestelmä toimii hitaasti muistiongelman vuoksi

SLN284387_en_US__11381136142451.1366966165505.D2

(Kuva 1.1 Tilan merkkivalot)

SLN284387_en_US__21381136167296.1372679222.led

(Kuva 1.2 Tilan merkkivalot)

  • Järjestelmä hidas, lakkaa vastaamasta tai ei vastaa, esimerkiksi siniset virhenäytöt

SLN284387_en_US__31381136186047.20090530213015

(Kuva 2 Sininen näyttö -virhe: NMI-pariteettivirhe)

  • Näyttöön tulevat virheilmoitukset muistin pysäytyksistä, ylivuodoista, koosta tai lukuongelmista

SLN284387_en_US__41381136321989.svchost-application-error

(Kuva 3.1 Sovellusvirhe)

SLN284387_en_US__51381136342647.Muisti loppunut

(Kuva 3.2 Sisäinen virhe)

SLN284387_en_US__61381136362710.VMemory_error

(Kuva 3.3 Sovelmavirhe)

  • Ongelmia ohjelmistojen tai käyttöjärjestelmien (käyttöjärjestelmän) asentamisessa

Suurin osa tästä vianmäärityksestä tehdään osana tietyn vian erityistä vianmääritysopasta. Tämä artikkeli on yleiskatsaus, joka saattaa olla hiukan tavallista yksityiskohtaisempi.

Alkuun


Diagnostics

Tässä artikkelissa käsitellään eri mallien diagnostiikkamerkkivaloja ja -koodeja.

  1. Tarkista ensin, toimiiko PSA (Pre-Boot System Assessment) -diagnostiikka.

    Kun tietokone on sammutettu, pidä Fn-näppäintä ja virtapainiketta painettuna samanaikaisesti. Vaihtoehtoisesti voit napauttaa nopeasti F12-näppäintä tietokoneen käynnistyessä ja valita näkyviin tulevasta muistista Diagnostiikka . Näytön oikeassa yläkulmassa pitäisi näkyä Diagnostic Boot Selected -ilmoitus.

    HUOMAUTUKSIA:
    • Jos voit käyttää verkkoa, voit tehdä muistikohtaisen diagnostiikan. Siirry muistin verkkodiagnostiikkasivulle.
      HUOMAUTUKSIA:
      • Diagnostiikka käynnistyy automaattisesti.
      • Saat ehkä kehotteen asentaa tai päivittää SupportAssist-ohjelma. Toimi ohjeiden mukaisesti.
      • Se saattaa kestää 10–15 minuuttia tietokoneen laitteiston mukaan.
    • Voit tehdä diagnostiikan myös tukisivustossamme.
      • Pikatesti: tämä laitteistotesti saattaa kestää 10–15 minuuttia tietokoneen laitteiston mukaan.
      • Täysi testi: Tämä on perusteellinen testi. Se saattaa kestää 40 minuuttia tai kauemmin tietokoneen laitteiston mukaan.
      • Mukautettu komponenttitesti - Valitse vähintään yksi laitteistotesti, jonka haluat suorittaa.

        Tee tietyn laitteen testi seuraavasti:

        1. Siirry Dellin tukisivustoon.
        2. Voit tunnistaa tietokoneen kolmella tavalla.

          Tee jompikumpi:

          • Valitse tietokoneesi TÄMÄ TIETOKONE -kohdassa.
            HUOMAUTUS: Jos tietokoneesi ei ole kohdassa TÄMÄ tietokone, voit valita Lataa ja asenna SupportAssist. Se tunnistaa tietokoneesi automaattisesti. Lataa ja asenna SupportAssist ohjeiden mukaisesti.
          • Anna palvelutunnus, Dell-tuotetunnus tai malli, valitse hakupainike ja valitse tietokone luettelosta.
          • Valitse Selaa kaikkia tuotteita: Valitse laitteen tyyppi, nimi ja tuotemalli.
            HUOMAUTUS: Lisätietoja on Dellin tietokanta-artikkelissa Dell-tietokoneen tuotemallin selvittäminen.
        3. Valitse VIANMÄÄRITYS-välilehti.
        4. Valitse Mukautettu komponenttitesti -välilehdestä Select individual components.
        5. Valitse testattavien osien vierellä oleva valintaruutu.
        6. Valitse Suorita testi ja noudata näyttöön tulevia ohjeita.
  2. Tietokone suorittaa noin 15-20 minuutin laitteiston itsetarkistukset. Kun nämä ovat valmiita, se kysyy, haluatko suorittaa seuraavat muistitestit, jotka voivat kestää vielä 30 minuuttia +. Jos PSA-testit onnistuvat, tee muistin lisätestit.

    1. Jos kaikki testit läpäisevät, sinun kannattaa siirtyä ohjelmiston vianmääritykseen.

    2. Jos järjestelmä ei läpäise niitä, merkitse virhekoodi muistiin ja siirry seuraavaan vaiheeseen.

  3. Jos sinulla on virhekoodi, sinun kannattaa tarkistaa alla oleva opas. Se kertoo, voitko suorittaa uudemman edistyneen vianmäärityksen tietokoneessasi. Nämä vianmääritykset tunnistavat DIMM-muistimoduulin tai tietokoneen korttipaikan vian.

    1. Jos diagnostiikka on mahdollista ja olet päivittänyt siihen tietokoneellasi. Ota yhteyttä tukeen ja lue diagnostiikan tulokset, jotta voit viedä asiaa eteenpäin.

    2. Jos diagnostiikka ei onnistu tietokoneessa tai et pysty päivittämään siihen. Seuraavaksi on vuorossa laitteiston vianmääritys.

    HUOMAUTUS: Voit lähettää palvelutunnuksen, ePSA-virheen ja vahvistuskoodinSupportAssist Pre-Boot System Performance Check - sivulla.
Huomautus: Onko sinulla Dellin kannettava tietokone? Kun lähetät kannettavan tietokoneesi takuun piiriin kuuluviin korjauksiin, diagnosoimme ja ratkaisemme käynnistysongelman. Palvelu on saatavana Kanadassa, Ranskassa, Saksassa, Italiassa, Alankomaissa, Puolassa, Yhdistyneessä kuningaskunnassa ja Yhdysvalloissa.

Alkuun


Laitteiston vianmääritys

Laitteistomuistin vianmäärityksen idea on yksinkertainen. Kyse on osien vaihtamisesta ja tunnetusti toimivien osien käyttämisestä.

Kaikki kannettavat tietokoneet, joissa on irrotettava muisti, pääsevät muistiin yksikön pohjan kautta. Joko alapaneeli irtoaa tai siinä on irrotettava luukun kansi. Tietokoneen käyttötavat ovat Dell-järjestelmän huolto- ja käyttöoppaissa.

  1. No Post -tilanteessa muisti poistetaan ensin tietokoneesta kokonaan. Muuttuuko vikatilanne?

    1. Jos kyllä, siirry vaiheeseen 2.

    2. Jos näin ei ole, sinun kannattaa seurata alla olevaa No Post Guide -opasta.

  2. Onko sinulla tunnetusti hyvä samanlainen tietokone tai tunnettu hyvä työmuisti, jonka voisit vaihtaa tähän tietokoneeseen?

    1. Kyllä, vaihda sitten hyväksi tunnettu muisti tämän laitteen muistiin ja katso, missä vika menee. Ota yhteyttä tukiedustajaasi ja vie asia eteenpäin hänen kanssaan.

    2. Ei, siirry seuraavaan vaiheeseen.

  3. Useimmissa kannettavissa tietokoneissa on tällä hetkellä yksi tai kaksi muistimoduulia. Tyypillisimmin se on kaksi, koska suurin osa muistista on suunniteltu toimimaan paremmin yhteensopivissa pareissa. Seuraava vaihe on sama riippumatta muistimoduulien määrästä. Ota yksi DIMM-moduuli ja testaa sitä jommassakummassa muistiliitännässä. Merkitse tulokset muistiin ja tee samoin mahdollisen toisen DIMM-moduulin kanssa. Muuttuuko vikatilanne sen mukaan, mitä DIMM-moduulia tai muistipaikkaa käytät?

    1. Kyllä. Jos vika seuraa DIMM-moduulin mukana tai pysyy tietyssä emolevyn muistipaikassa, olet löytänyt vian syyn. Hyvä uutinen on, että voit käyttää konetta pienemmällä muistilla, kunnes olet ottanut yhteyttä tukeen ilmoittaaksesi viasta.

    2. Ei. Onko vika sama riippumatta siitä, mihin DIMM-moduuliin tai paikkaan muisti on asennettu? Tällöin vika ei ole muistissa tai sekä muisti että korttipaikat ovat viallisia. Siksi suosittelemme vaihetta 2. Suosittelen ottamaan yhteyttä tukeen viedäksesi asiaa eteenpäin.

Alkuun


Ohjelmistojen vianmääritys

Muistiongelmien ohjelmiston vianmääritysvaiheet ovat lyhyitä ja käsittelevät enimmäkseen virtuaalimuistia fyysisen muistin sijaan.

  1. Windowsissa voi tehdä lisää muistin diagnostiikkaa. Valittavissa on monenlaisia tunnettuja testejä, kuten Memtest. Todennäköisesti käytetään kuitenkin jo PSA-diagnostiikasta saatuja tuloksia Varsinkin kun PSA: t sisällyttävät Memtest-diagnostiikan testeihinsä. Jos saat virheen kolmannen osapuolen diagnostiikasta, tarkistamme, että ne ovat yhteensopivia. Tarvitsemme myös avaimen kolmannen osapuolen virhekoodeihin. Tämä kannattaa ohittaa ja siirtyä seuraavaan vaiheeseen.

  2. Virtuaalimuistin virheen sulkemiseksi suosittelen tarkistamaan pari nopeaa asiaa tietokoneellasi. Ensin kannattaa varmistaa, että Windows käsittelee näennäismuistia. Siirry laitteistoikkunan Ohjauspaneeli ja suorituskyky -kohtaan ja tarkista asetukset. Muuta asetuksia tarvittaessa. Tarkista, mistä osiosta näennäismuisti varataan. Tietokone varaa kiintolevyltä tilaa muistikäyttöön fyysisen muistin lisäksi. Tiedot ovat samassa paikassa, jossa vahvistat tietokoneen käsittelevän muistia. Tarkista kyseinen osio ja varmista, että siinä on vähintään 6–10 Gt vapaata tilaa. Useimmat sivutustiedostot ovat vain 2-4 Gt, mutta jos henkilökohtainen tietokone käsittelee tätä, se voi muuttaa kokoa tarpeen mukaan. Kun olet määrittänyt tämän, testaa tietokone ja katso, toistuuko vika. Jos niin on, siirry seuraavaan vaiheeseen.

    Näennäismuisti

    Jos tietokoneessa ei ole ohjelman tai toiminnon suorittamiseen tarvittavaa RAM-muistia, Windows kompensoi sen näennäismuistilla.

    Näennäismuisti yhdistää fyysisen RAM-muistin kiintolevyn tilapäistilaan. Kun RAM-muisti on vähissä, näennäismuisti siirtää tietoja RAM-muistista tilaan, jota sanotaan sivutustiedostoksi. Tietojen siirtäminen sivutustiedostoon ja siitä pois vapauttaa RAM-muistia.

    Mitä enemmän RAM-muistia tietokoneessa on, sitä nopeammin ohjelmat toimivat. Jos RAM-muistin puute hidastaa tietokoneen toimintaa, näennäismuistin lisääminen saattaa tuntua houkuttelevalta. Tietokoneesi voi kuitenkin lukea tietoja RAM-muistista nopeammin kuin kiintolevyltä, joten RAM-muistin lisääminen on parempi ratkaisu.

  3. Voit seurata muistin käyttöä Tehtävienhallinnassa ja tapahtumalokin poikkeuksista. Siten voit seurata, oliko jokin tietty ohjelma, prosessi tai laite käytössä virhetilanteen aikana. Entä onko muistin käyttöaste suuri? Jos pääset Windows-ympäristöön seuraamaan näitä, se vähentää tarkistettavien ongelmien määrää. Olen lisännyt alle linkin hyppysivulle, jossa on oppaita näistä menetelmistä kullekin eri käyttöjärjestelmälle.

    1. Jos Tehtävienhallinta näyttää suurta muistin käyttöä, saatat tarvita enemmän muistia, koska asennettuna ei ole tarpeeksi kaikkien haluamiesi töiden suorittamiseen tietokoneellasi. Se tarkoittaa alkuperäisen muistin korvaamista suuremmilla DIMM-moduuleilla, jotka olet ostanut.

    2. Jos Tehtävienhallinta osoittaa, että ongelma liittyy käyttöjärjestelmään, ohjelmaan tai prosessiin. Voit käyttää ilmaista kolmannen osapuolen haittaohjelmien tarkistajaa, kuten Malware bytes. Jos ongelma jatkuu, korjaa ongelma palauttamalla käyttöjärjestelmäversiosi tai asentamalla se uudelleen. 

Alkuun

Informations supplémentaires

Suositellut artikkelit

Seuraavassa on joitakin aiheeseen liittyviä artikkeleita, jotka saattavat kiinnostaa sinua.


Tuki takuun päätyttyä Takuu päättynyt? Selaa Dell.com/support sivustoa, anna Dell-palvelutunnisteesi ja katso tarjouksemme.

HUOMAUTUS: Tarjoukset ovat käytettävissä ainoastaan Yhdysvalloissa, Kanadassa, Yhdistyneessä kuningaskunnassa, Ranskassa, Saksassa ja Kiinassa (tietokoneasiakkaat). Ei koske palvelin- ja tallennustuotteita.

Produits concernés

Chromebook, G Series, Alienware, Inspiron, Latitude, Vostro, XPS, Legacy Laptop Models, Mobile Workstations
Propriétés de l’article
Numéro d’article: 000126066
Type d’article: Solution
Dernière modification: 10 Oct 2024
Version:  18
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.