Symptômes
Os engenheiros da Dell identificaram um problema pouco frequente durante as operações do sistema ao usar a SSD Express Flash NVMe PCIe Dell PM1725a, em que o dispositivo pode ficar off-line e permanecer inacessível. A unidade pode ficar acessível novamente após uma reinicialização.
Erros como "nvme_remove_namespaces", "nvme0n1: detectada mudança de capacidade de xxxxxxxxx para 0" e vários erros do file system podem ser vistos em /var, /log, /messages ou em outros registros de eventos do sistema. Além disso, o uso contínuo da SSD exigiria a recriação do file system. Este problema foi resolvido com uma correção de firmware.
Cause
O problema é causado por uma falha no gerenciamento de cache. Quando o buffer de cache de gravação está cheio, o controlador descarta erroneamente uma operação de GRAVAÇÃO de entrada do host. Isso é resolvido com a manutenção de operações de GRAVAÇÃO de entrada do host após a limpeza do conteúdo do cache.
Résolution
O problema foi resolvido em abril de 2019 com o firmware versão 1.1.2 (A03) da SSD Express Flash NVMe PCIe Dell PM1725a.
Nota: Como todas as versões do firmware anteriores à 1.1.2 para dispositivos PM1725a estão suscetíveis a esse problema, firmwares de outras versões foram removidos do site de suporte da Dell e não estão mais disponíveis para download.
Produits concernés
Storage Spaces Direct R640 Ready Node, Storage Spaces Direct R740xd Ready Node, PowerEdge R640, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R830, PowerEdge R840