Symptômes
Bei der Verwendung der Express Flash NVMe PCIe SSD PM1725a von Dell ist während des Systembetriebs ein seltenes Problem aufgetreten, bei dem das Gerät möglicherweise offline geschaltet wird und nicht mehr erreichbar ist. Das Laufwerk ist möglicherweise nach einem Neustart wieder zugänglich.
Fehler wie "nvme_remove_namespaces", "nvme0n1: detected capacity change from xxxxxxxxx to 0" und verschiedene Dateisystemfehler können in /var, /log, /messages oder anderen Systemereignisprotokollen angezeigt werden. Außerdem müsste das Dateisystem für die weitere Verwendung der SSD neu erstellt werden. Dieses Problem wurde durch eine Firmware-Korrektur behoben.
Cause
Das Problem wird durch einen Fehler in der Cacheverwaltung verursacht. Wenn der Schreibcachepuffer voll ist, löscht der Controller fälschlicherweise einen eingehenden WRITE-Vorgang vom Host. Dies wird behoben, indem eingehende Schreibvorgänge vom Host bearbeitet werden, nachdem der Inhalt des Caches geleert wurde.
Résolution
Das Problem wurde mit der Firmware-Version 1.1.2, A03 der Dell Express Flash NVMe PCIe SSD PM1725a von April 2019 behoben.
HINWEIS: Da alle Versionen der PM1725a-Firmware vor 1.1.2 von diesem Problem betroffen sind, wurden alle anderen Firmwareversionen als 1.1.2 von der Dell Support-Website entfernt und steht nicht mehr zum Herunterladen zur Verfügung.
Produits concernés
Storage Spaces Direct R640 Ready Node, Storage Spaces Direct R740xd Ready Node, PowerEdge R640, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R830, PowerEdge R840