Omitir para ir al contenido principal
  • Hacer pedidos rápida y fácilmente
  • Ver pedidos y realizar seguimiento al estado del envío
  • Cree y acceda a una lista de sus productos

Як вирішити проблему із завантаженням після запуску відновлення Ubuntu в операційній системі

Resumen: У цій статті ви дізнаєтеся, як відновитися після проблеми без завантаження ноутбука Dell за допомогою операційної системи Ubuntu.

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

У наступній статті представлена інформація про проблему із завантаженням операційної системи після запуску інструменту відновлення операційної системи Ubuntu на ноутбуках Dell.


Ваш ноутбук Ubuntu не завантажується після запуску інструменту відновлення?

На етапі відновлення основний жорсткий диск зазвичай призначається як / dev/sda , щоб продовжити відновлення системи.

Однак у деяких випадках кардрідер Realtek RTS5170 випадково повідомляє про кардрідер як / dev/sda, випереджаючи справжній жорсткий диск.

Коли це станеться, основний жорсткий диск буде призначено як / dev/sdb .

Це означає, що при наступному перезавантаженні системи після завершення відновлення, менеджер завантаження буде шукати основний жорсткий диск в неправильному місці, оскільки основний жорсткий диск буде зміщено в / dev/sda. Зміна запису менеджера завантаження призведе до того, що система не завантажиться і зупиниться на екрані, показаному нижче:

Gave up waiting for root device. Common problem:
 - Boot args (cat /proc/cmdline)
 - Check rootdelay: (did the system wait long enough?)
 - Check root: (did the system wait for the right device?)
 - Missing modules (cat /proc/modules: ls /dev)
ALERT! /dev/disk/by-uuid/e279d132-d5b4-42a6-932f-225b4be3f0c8 does not exist. Dropping to a shell!

BusyBox v1.21.1 (Ubuntu 1:1.21.0-1ubuntu1) built in shell (ash)
Enter 'help' for a list of built-in-commands.

(initramfs) _

Causa

Інформація про причину недоступна.

Resolución

  1. Завантажте останній образ Ubuntu LTS з Ubuntu.com. Це гіперпосилання спрямовує вас на веб-сайт за межами Dell Technologies.

  2. Створіть завантажувальний USB-накопичувач або DVD-диск з образом Dell Ubuntu.

    • Запис завантажувального DVD Ubuntu на робочий ПК з Windows (Windows 7 / 8)::

      1. Клацніть правою кнопкою миші завантажений ISO-образ і виберіть Відкрити за допомогою > записувача образів дисків Windows.

      2. Виберіть розташування пристрою читання DVD-RW і натисніть кнопку Записати. (Я рекомендую вам перевірити параметр Перевірити диск після запису , він підтвердить, що образ записано правильно.)

    • Запис завантажувальної флешки Ubuntu на робочий ПК з Windows (Windows 7 / 8):

      1. Завантажте інсталятор USB, наприклад USB-інсталятор Pen Drive Linux. Це гіперпосилання спрямовує вас на веб-сайт за межами Dell Technologies.

      2. Для цього конкретного інсталятора - виберіть Ubuntu з випадаючого списку.

      3. Натисніть «Огляд» і відкрийте завантажений ISO-образ.

      4. Виберіть USB-накопичувач і натисніть «Створити».

  3. Завантажте систему з USB-накопичувача або створеного DVD-диска. Можливо, вам доведеться швидко натиснути клавішу F12 на екрані логотипу Dell під час увімкнення системи, щоб викликати на екрані меню вибору завантажувального пристрою. (Виберіть параметр, який відповідає медіафайлу, який ви використовуєте.)

  4. Виберіть опцію Спробувати Ubuntu без встановлення в меню завантаження носія.

  5. Після цього ви завантажитеся на робочому столі, але нічого не встановите на жорсткий диск. Перебуваючи на робочому столі, натисніть одночасно клавіші Ctrl+Alt+T , щоб відкрити вікно терміналу. Виконайте наведені нижче дії, щоб вирішити проблему з розташуванням завантаження:

    1. Змінити на корінь.

      sudo –s

    2. Перемонтуйте CDRom, щоб встановити для нього режим читання-запису.

      mount –n –o remount, rw /cdrom/

    3. Введіть команду.

      cd /cdrom/factory

    4. Відредагуйте файл / cdrom/factory/common.cfg за допомогою редакторів vi або gedit . Змініть оригінальну команду на set options="boot=casper automatic-ubiquity noprompt quiet splash -- modprobe.blacklist=rts5139 nomodeset"

    5. Збережіть файл, вийдіть з редактора і вікна терміналу і перезавантажте систему.

  6. Якщо система все одно не завантажується, спробуйте виконати такі дії:

    1. Переконайтеся, що обладнання працює нормально, запустивши діагностику.

      1. Якщо з чогось не виходить, зверніться до служби технічної підтримки та передайте повідомлення про помилку та код перевірки.

      2. Якщо вона пройде, то приступають до наступного кроку.

    2. Запустіть наступну команду в Терміналі:

      ls -lah

    3. Якщо у вас з'явилося щось інше, ніж drwxrwxrwt, запустіть таку команду:

      chown username: username .Xauthority

    4. Якщо це не допомогло, запустіть:

      sudo chmod a+wt /tmp

    5. Також можна спробувати бігати:

      dpkg-reconfigure lightdm

    6. Якщо жодна з цих функцій не допомогла, то вам слід відновити дані з образу системи або резервного носія.


Додаткова інформація:

Примітка: Підтримка програмного забезпечення здійснюється компанією Canonical наступними методами:
Технічну підтримку надає компанія Dell:
Примітка: У вас є ноутбук Dell? Надішліть ноутбук на гарантійний ремонт, і ми виявимо та усунемо проблему, якщо ноутбук не завантажується. Наразі ця послуга доступна в Канаді, Франції, Німеччині, Італії, Нідерландах, Польщі, Великій Британії та США.

Productos afectados

Inspiron
Propiedades del artículo
Número del artículo: 000129823
Tipo de artículo: Solution
Última modificación: 31 may. 2024
Versión:  6
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.