Omitir para ir al contenido principal
  • Hacer pedidos rápida y fácilmente
  • Ver pedidos y realizar seguimiento al estado del envío
  • Cree y acceda a una lista de sus productos

Rozwiązywanie problemu z błędem przypinania pamięci Intel Optane: Nie można załadować biblioteki DLL „iaStorAfsServiceApi.dll”

Resumen: W tym artykule wyjaśniono, jak rozwiązać i zapobiec ponownemu wystąpieniu błędu "Unable to load DLL 'iaStorAfsServiceApi.dll'' po przyszłej aktualizacji systemu operacyjnego.

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas


Począwszy od wersji 17.5.0.1017 sterownika Intel Rapid Storage Technology (RST), nastąpiła zmiana w instalacji elementów przypinania pamięci Intel® Optane™.

Podczas aktualizacji sterowników, na przykład z wersji 16.8.x do 17.5.x lub 17.8.x, aktualizacja systemu operacyjnego może próbować użyć usuniętych plików instalacyjnych ze starszej wersji. Może to spowodować wyświetlenie komunikatu o błędzie.

SLN322012_en_US__1icon Uwaga: Ten problem nie dotyczy komputera z fabrycznie zainstalowanym systemem operacyjnym (OS), na którym zainstalowano sterowniki Intel RST w wersjach od 17.5.x do 17.8.x.

 


Causa

Brak informacji o przyczynie

Resolución


  1. Aby rozwiązać ten problem, napraw bieżące rozszerzenia przypinania pamięci Intel® Optane™, wykonując następujące czynności.
    1. Otwórz aplet Programy i funkcje.

      Aby otworzyć okno Programy i funkcje, wykonaj następujące czynności:

      1. Naciśnij i przytrzymaj klawisz Windows (SLN322012_en_US__2iC_Windows_Key_BD_v4), a następnie naciśnij klawisz r.
    2. W polu Uruchom wpisz "appwiz.cpl" i dotknij przycisku OK.
    3. Odszukaj i zaznacz Intel Optane Pinning Explorer Extensions.
    4. Dotknij lub kliknij opcję Napraw.

  2. Aby błąd nie pojawił się ponownie po następnej aktualizacji systemu operacyjnego, odinstaluj stary pakiet.
    1. Otwórz Menedżer urządzeń.

      Aby otworzyć Menedżer urządzeń, wykonaj następujące czynności:

      1. Naciśnij i przytrzymaj klawisz Windows (SLN322012_en_US__2iC_Windows_Key_BD_v4), a następnie naciśnij klawisz x.
      2. Z listy wybierz pozycję Menedżer urządzeń.

    2. Dotknij lub kliknij strzałkę na lewo od opcji Składniki programowe.
    3. Kliknij prawym przyciskiem myszy pozycję Intel® Pinning Shell Extensions i wybierz opcję Odinstaluj urządzenie.
    4. Dotknij lub kliknij, aby zaznaczyć pole wyboru Usuń oprogramowanie sterownika dla tego urządzenia, a następnie dotknij lub kliknij Odinstaluj.
    5. Uruchom ponownie komputer.

Productos afectados

Inspiron 7786 2-in-1
Propiedades del artículo
Número del artículo: 000132090
Tipo de artículo: Solution
Última modificación: 22 jul 2024
Versión:  4
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.