Symptoms
The Hardware Lifecycle Host (HLH) is stuck with a BitLocker Recovery prompt. This leaves the Operation System Deployment (OSD) workflow from the Patch and Update Tool in a failed state.
Cause
The Operating System Deployment (OSD) workflow performs firmware updates first. During the reboot of the Hardware Lifecycle Host (HLH), the BitLocker Recovery prompt is displayed and the workflow is unable to resume.
Resolution
Export the BitLocker Recovery key from the Hardware Lifecycle Host (HLH) before to starting the Patch and Update OSD workflow. The recovery key can be found in the following location - D:\CustomerBackup.
When prompted, enter the BitLocker Recovery key and allow the Hardware Lifecycle Host (HLH) to fully boot. Once the Hardware Lifecycle Host (HLH) has booted, click the retry button in the Patch and Update Tool.
Affected Products
Integrated System for Microsoft Azure Stack Hub