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Unable to Perform Quick Multiple Barcode Scans with Rugged Control Center

Summary: This article provides information about how to improve scanning speed to perform multiple barcode scans with Rugged Control Center.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

When the barcode scans are performed consecutively, the barcode may not be completely logged by the computer.

The issue occurs when the user is not waiting long enough after the previous barcode scan.

Affected Platforms:

  • Latitude 7212 Rugged Extreme Tablet
  • Latitude 7220 Rugged Extreme Tablet
  • Latitude 7220EX Rugged Extreme Tablet

Affected Software:

  • Rugged Control Center

Affected Versions:

  • 4.6.38.0

Cause

This is due to the new Application Programming Interface (API) provided by Microsoft which Rugged Control Center version 4.6 is built on. This is unavoidable as this solution is not intended for rapid scanning due to the implementation of the buffer.

A new API was implemented to ensure compatibility with newer barcode scanners.

Resolution

Updating to Rugged Control Center version 4.7.123.0, A00 or later on the computer resolves the issue. However, the speed will not be as fast as in older versions. To download and install the application, reference How to Download and Install Dell Drivers.

Affected Products

Latitude 7212 Rugged Extreme Tablet, Latitude 7220EX Rugged Extreme Tablet, Latitude 7220 Rugged Extreme Tablet, Rugged Control Center
Article Properties
Article Number: 000216254
Article Type: Solution
Last Modified: 22 Oct 2024
Version:  2
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