Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

PowerVault ME5:管理インターフェイスにアクセスできない、または応答しない

Summary: 管理者は、PowerVault Managerにアクセスできない、SSHセッションを開くことができない、またはシリアル セッションにログインできないと報告することがあります。ストレージ コントローラーは、接続されているフロントエンド ホストにデータを提供し続けます。コントローラー ファームウェアをバージョンME5.1.2.1.0以降にアップグレードします。

This article applies to   This article does not apply to 

Symptoms

マネジメント コントローラー(MC)とストレージ コントローラー(SC)は、MEシリーズ アレイでは別々のサブシステムです。アレイはI/Oを処理し続けますが、すべての管理インターフェイス(UI、SSH、シリアル、SNMP、REST API)が応答しなくなります。
 

注:元の記事では、ME5.1.2.0.1以降にアップグレードすることをお勧めします。  この記事は、コントローラー ファームウェアME5.1.2.1.0へのアップグレードを推奨するように更新されました。これには、SNMPまたはREST APIコールを使用する外部管理アプリケーションからのプローブで管理コントローラーが再起動するのを防ぐための追加の修正が含まれています。

一般的な症状: 
  • PowerVault Manager UIにアクセスできません。
  • 片方または両方の管理インターフェイスに対してSSHセッションを開くことができません。
  • シリアル セッションCLIポートにログインできません
  • アレイが応答しない、または外部管理アプリケーション(SNMPまたはREST API)から消えた。

後でイベント ログを確認したら、以下の解決手順を参照してください。進行中のファームウェア アップグレードがない場合でも、管理者のイベント履歴ログに次のエントリーが表示されることがあります。

...
B849       2023-08-08 01:08:16  152   WARNING        The Storage Controller is not receiving data from the Management Controller. (This is normal during firmware update.)
...

Cause

メモリー不足の状態が発生すると、管理アプリケーション プロセスが終了します。外部管理アプリケーションがSNMPまたはREST APIを使用して管理インターフェイスをポーリングしている環境では、発生頻度が高くなる可能性があります

ME5リリース ノート: 
FMW-65056CLIおよびユーザー インターフェイスが応答しなくなる可能性がある状態を解決

どのシステムが影響を受ける可能性がありますか?

製品(およびバージョン)  次のDell PowerVault ME5シリーズ ストレージ システム
  • PowerVault ME5012
  • PowerVault ME5024
  • PowerVault ME5084
次のコア ソフトウェアを実行
(オペレーティング システムまたは操作環境)
バージョンME5.1.2.0.1より前のPowerVault ME5コントローラー ファームウェア
 

Resolution

  1. 可能であれば、各コントローラー管理インターフェイスへのSSHセッションを開くか、USBシリアル接続を開いて、管理コントローラー サービスを再度開始します。これが成功した場合は、コントローラー ファームウェアをアップグレードします。
  2. SSHまたはUSBシリアルを使用してログインできない場合は、影響を受けるコントローラー モジュールのいずれかを物理的に抜き差しし、このコントローラーで管理制御が回復したら、ピア コントローラーを再起動する必要があります。単一のコントローラー モジュールを搭載したアレイ、またはパスの冗長性のないホストを含む構成のアレイでは、メンテナンス ウィンドウを調整し、ホストをシャットダウンしてからアレイの電源をオフにする必要があります。
  3. 両方のコントローラー モジュールへの管理アクセスが再確立されたら、コントローラー モジュールのファームウェアをバージョンME5.1.2.1.0以降にアップグレードします。

手順:

手順1:両方のコントローラーで管理サービスの再起動を試みます。

  • この手順は、状況によっては実行できない場合があります。管理コントローラーを再起動しても、本番環境には影響しません。 
  • この手順で管理セッションが終了し、約2、3分後にサービスが再起動されると、管理アクセスがリストアされます。   
  • 両方のコントローラー モジュールで管理サービスを正常に再起動できる場合は、 手順3に進みます。コントローラー モジュールのファームウェアをME5.1.2.1.0以降にアップグレードします。 
  1. 各コントローラーの管理インターフェイスへのSSHセッションを開き、管理レベルまたは管理者レベルのユーザーとしてログインします。または、管理者は各コントローラーへのUSBシリアル接続を試すことができます。SSHまたはシリアル接続を使用してログインできない場合は、手順2に進みます。1つのコントローラー モジュールを物理的に抜き差しするか、アレイの電源を切ります。   
  2. ログインが成功したら、次のコマンドを使用して、それぞれの管理コントローラーを再起動します。 
    restart mc full
    
    # restart mc full
    During the restart process you will briefly lose communication with the specified Management Controller(s).
    Do you want to continue? (y/n) y
    
    Info: Restarting the local MC (A)...
    Success: Command completed successfully. (2023-08-24 05:34:01)
    # Killed


手順2:1つのコントローラー モジュールを物理的に抜き差しするか、アレイの電源を切ります。 

警告:コントローラーを取り外すと、ホストのデータへのアクセスが中断する可能性があり、状況によっては、予期しないアウテージや潜在的なデータ ロスを防ぐために、ホストI/Oを事前に停止する必要があります。

シナリオ1:冗長パス ホスト構成を備えたデュアル コントローラー

これらの手順は、メンテナンス ウィンドウを必要とせずに実装できます

次の条件が満たされている必要があります。

  • ホストには、コントローラーAおよびBへの接続パスが必要です
  • ホストでマルチパス サポートが構成され、有効になっている必要があります。 
  • すべてのホスト イニシエーターがボリュームにマッピングされている必要があります。

手順については、『Dell PowerVault ME5シリーズ ストレージ システム オーナーズ マニュアル』の「モジュールの取り外しおよび交換>顧客交換可能ユニット」セクションを参照してください。 

  1. コントローラー モジュールBをスロット内で物理的に約5センチメートル(約2インチ)前方に引き、30秒後にコントローラー モジュールを取り付け直します。
  2. コントローラーBの起動とファームウェアのロードが完了するまで、約2〜3分かかります。 
  3. コントローラーBの管理IPアドレスへのSSHセッションを開き、管理レベルまたは管理者レベルのユーザーとしてログインします。 
  4. ピア ストレージ コントローラーAを再起動します。次のコマンドを入力します。 
    restart sc a 
    
    # restart sc a While a Storage Controller is restarting, communication will temporarily be lost with the corresponding Management Controller, and also may cause a temporary loss of data availability. Do you want to continue? (y/n) y Success: Command completed successfully. - The command to restart SC A completed successfully. The controller will restart in approximately 30 seconds. (2023-08-24 07:08:39)
  1. ピア コントローラーがオンラインになったら、PowerVault Managerにログインし、 手順3に進みます。コントローラー モジュールのファームウェアをME5.1.2.1.0以降にアップグレードします。

シナリオ2:シングル コントローラー モジュールまたは非冗長ホスト パス構成

メンテナンス ウィンドウが必要です。データへの単一のパスを予期せず削除すると、ホストはデータにアクセスできなくなり、応答を停止します

手順については、『Dell PowerVault ME5シリーズ ストレージ システム オーナーズ マニュアル』の「モジュールの取り外しと交換>顧客交換可能ユニット」セクションを参照してください。 

  1. アウテージをユーザーに通知し、ホスト オペレーティング システムのユーザー ガイドに従って、接続されているホストをメンテナンス モードにするか、ホストをシャットダウンします。 
  2. アレイ背面で、両方の電源装置の電源を約60秒間オフにしてから再度オンにします。
  3. コントローラーの起動が完了し、ファームウェアがロードされるまで約3分かかります。
  4. PowerVault Managerにログインし、 手順3に進みます。コントローラー モジュールのファームウェアをME5.1.2.1.0以降にアップグレードします。

手順3:コントローラー モジュールのファームウェアをME5.1.2.1.0以降にアップグレードします。

Dell PowerVault ME5シリーズ管理者ガイド「システム ファームウェアのアップデート」セクションを参照してください。

  • コントローラー ファームウェア アップデートをダウンロードします。Webブラウザーで、Dellサポートを開きます
  • PowerVault MEサービス タグを入力するか、PowerVault MEモデルを選択します。
  • [マニュアル]で、『Dell PowerVault ME5ストレージ システム リリース ノート』を選択します。
  • [ドライブおよびダウンロード]タブで、Dell PowerVault ME5シリーズ ストレージ コントローラー ファームウェアをダウンロードします
  • .zipファイルからファームウェア バイナリを抽出します。
  • Dell PowerVault Managerの使用。[Maintenance]>Firmware >Systemに移動して、ファームウェア バイナリー ファイルをアップロードします。
  • Maintenance >Firmware >Systemに移動し、Activate this Versionリンクをクリックしてダイアログを表示します。
  • 画面に表示される指示に従って、アクティベーションを開始します。

アップグレード後の動作:

ME5コントローラー ファームウェア バージョンME5.1.2.0.1以降では、管理者が次の情報アラートを受け取ることがあります。 

情報アラート

図1: 情報アラート

The Management Controller entered a memory exhaustion state and will reboot to recover. Data access will not be interrupted.


管理コントローラー(MC)は、システムを監視および設定するための管理UIとCLIインターフェイスを提供します。Management Serviceを再起動しても、コントローラーが再起動されたり、I/Oが中断されたりすることはありません。再起動の影響は、管理インターフェイスに2分間アクセスできなくなることです。この情報アラートを頻繁に受信する場合は、原因を特定するためにさらに調査が必要になる場合があります。 
 

メモ: システム管理者は、ネットワーク スイッチでのブロードキャスト ストームやスパニング ツリー ループなどのサービス拒否を引き起こすEthernetスイッチの障害状態、セキュリティ脆弱性テスト スイート、またはREST APIを使用した外部スクリプトに注意する必要があります。REST APIは一定のループで実行され、複数のセッションを作成し、毎秒アレイをポーリングします。これにより、管理インターフェイスにアクセスできなくなるという同じ現象が発生する可能性があります。
 
 

Affected Products

ME Series, PowerVault ME5012, PowerVault ME5024, PowerVault ME5084
Article Properties
Article Number: 000215402
Article Type: Solution
Last Modified: 21 Jun 2024
Version:  15
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.