Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

Datadomene: Når du har oppgradert til DDOS/DDMC 7.1.x eller nyere, er det ikke lenger mulig å få tilgang til det grafiske grensesnittet

Summary: På grunn av strengere sikkerhetskontroller i DD og DDMC GUI-serverdelene etter DDOS/DDMC 7.1.x og nyere, kan det hende at noen sertifikater for klarerte DD-verter som ble godtatt tidligere, ikke er mulig etter oppgraderingen, noe som fører til manglende evne til å starte GUI-grensesnittet etter DDOS-oppgraderingen ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

En kunde oppgraderer enten DDOS eller DDMC til versjon 7.1.x eller nyere (vi vil bruke DDOS fra nå av for å referere til både DDOS og DDMC), for korthets skyld, og finner ut etter at oppgraderingen er fullført, at det ikke er mulig å få tilgang til GUI lenger. Å starte HTTP / HTTPS-tjenestene på nytt fra kommandolinjen får det heller ikke til å fungere. Når du bruker en nettleser for å få tilgang til GUI, vil følgende feilside vises: 
 

Tjenesten er ikke tilgjengelig

GUI-tjenesten er midlertidig utilgjengelig. Oppdater nettleseren for å prøve på nytt. Kontakt Dell EMC-støtte for hjelp hvis problemet vedvarer

Cause

GUI-backend kjører av et Java-basert program. GUI-backend kjører ikke. Hvis denne DD-en har blitt oppgradert til DDOS 7.1.x eller nyere, og det grafiske grensesnittet har sviktet siden, hvis DD har et klareringsforhold med andre DD-er og noen av dem har et sertifikat med en offentlig nøkkel som er kortere enn 2048 biter, kan det være årsaken til at DD-GUI-en ikke starter opp. som strengere kontroller i den nyere buntet JDK ikke klarer å passere for noen av de klarerte DD-vertene.

Resolution

Først er det nødvendig å fastslå at dette er akkurat det problemet som står overfor. For at dette skal være tilfelle, må alle betingelsene nedenfor gjelde:
  1. DD der GUI ikke starter opp, opplever GUI-problemer bare etter oppgradering til DDOS 7.1.x eller nyere
  2. Denne DD-en har et klareringsforhold til andre DD-er, der én eller flere av dem hadde kjørt en DDOS 5.4.x-versjon (eller eldre) eller DDMC 1.1 (eller eldre) tidligere
  3. Denne DD-en har et bestemt sett med logger for manglende start av GUI-backend

Punkt 1 ovenfor er selvforklarende. For å finne ut om 2 ovenfor gjelder, må du først få listen over klarerte verter i DD:

# adminaccess trust show

For hver av vertene denne er klarert med, sjekk oppgraderingshistorikken for å se om noen ble installert med DDOS 5.4 (eller tidligere) eller DDMC 1.1 (eller tidligere): 

# Historikk for systemoppgradering

Systemer installert med noen av versjonene ovenfor har sannsynligvis hatt et CA selvsignert sertifikat generert ved installasjon med offentlige nøkler bare 1024 biter lange, som ikke lenger godtas av JDK etter oppgradering til DDOS / DDMC 7.1. En mulig måte å finne ut om disse vertene har sertifikater med små offentlige nøkler, er å åpne GUI-en for dem og sjekke sertifikatdetaljene fra en nettleser (måten å gjøre det på varierer litt mellom nettlesere).


For å bekrefte element 3 (hvis feilloggene for DD GUI er for dette spesifikke problemet), kjører du følgende kommando for å åpne "em.info"-loggfilen:

# log view debug/sm/em.info


Og søk (bruk en skråstrek) for å søke etter disse loggene ("..." indikerer at noen logger ikke vises nedenfor for korthets skyld):

 

+-----+-----+-----+ SYSTEM (RE)START +-----+-----+-----+
...
26 Feb 2021 10:33:04,172 INFO [main] Angi navnet på øktinformasjonskapselen til 'JSESSIONID-ddem___HTTPS'26
Feb 2021 10:33:04,172 INFO [main] Angi xsrf-informasjonskapselnavnet til 'DD_SSO_TOKEN___HTTPS'26
Feb 2021 10:33:04,382 INFO [hoved] Injisere SUN-leverandørens X.509-fabrikk for å fikse valideringsproblemer
...
26 februar 2021 10:33:05,093 INFO [hoved] Reinitialisere sertifikatene mellom klienten og serveren

26 februar 2021 10: 33: 05,093 INFO [hoved] Laste inn sertifikatlagrene for systemet på nytt

26 Feb 2021 10:33:05,097 INFO [main] Ferdig med å laste inn sertifikatlagrene
på nytt 26 Feb 2021 10:33:05,097 ERROR [main] Exception during command execution: javax.net.ssl.SSLException - Error creating premaster secret. , vil prøve på nytt, forsøk # 1
26 februar 2021 10: 33: 05, 243 INFO [hoved] Re-initialisere sertifikatene mellom klienten og serveren
26 februar 2021 10: 33: 05,243 INFO [main] Laste inn sertifikatlagrene for systemet
på nytt 26 februar 2021 10:33:05,246 INFO [hoved] Lastet inn sertifikatlagrene på nytt

 Det vil indikere at noe av sertifikatet denne DD har importert som klarert har en kort nøkkel, og dermed kan GUI ikke starte.

Selv om DDOS 7.1 eller nyere fortsatt ikke laster inn det grafiske grensesnittet når det presenteres med sertifiseringer med små, offentlige nøkler, er problemet løst i koden for versjonene DDOS 6.2.1.40 og nyere og DDOS 7.2.0.50 og nyere, slik at hvis det lokale CA-sertifikatet har en liten fellesnøkkel når du oppgraderer til en slik utgivelse, Sertifikatet genereres på nytt med en lengre nøkkel.
 

I skrivende stund (august 2022) støttes ingen andre utgivelser enn DDOS 6.2.1.x (kun for DD2200- og DD250-maskinvare) og DDOS 7.x lenger, ingen midlertidig løsning er gitt, selv om du for de fornærmende DD-ene kan prøve å generere verten og CA-sertifikatet på nytt med lengre nøkler, og deretter fjerne og legge til tillit igjen mellom de berørte enhetene: 

# adminaccess trust del host dd-trusted-1 type mutual
# adminaccess certificate generate self-signed-cert regenerate-ca
# adminaccess trust add host dd-trusted-1 type mutual


 

Affected Products

Data Domain
Article Properties
Article Number: 000202263
Article Type: Solution
Last Modified: 21 Mar 2023
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.