Symptoms
此問題的影響為:
- 第 1 次或第 2 次嘗試透過 GUI 上傳時,將不會上傳 Candidate 檔案
- 主要 SP 會重新開機。
- Unisphere GUI 在 10-15 分鐘或更長時間內無回應
在重新建立映像至版本 3.1.13.10192168 的陣列上進行 GUI 升級時發現此問題。
注意:若存在檔案 /var/tmp/upgrade/upgrade.log 與目標版本 3.1.13.10192168,代表系統已升級,且未重新製作映像。
Cause
適用產品:
VNXe1600 – SP3 (3.1.13.10192168) 之後版本
受影響的區域:
從 HTML GUI 上系統升級程序的 Candidate 檔案上傳步驟。
附加螢幕擷取畫面,以提供「GUI_upgrade 問題」的參考
Resolution
使用以下 Uemcli 命令升級系統:
此程序所涉及的步驟為
1.執行狀況檢查:
Uemcli /sys/general healthcheck
uemcli -d 10.0.0.1 -u joe -p MyPassword456! /sys/general healthcheck
注意:在 Unisphere GUI 中,此步驟未發現任何問題。
2.上傳檔案:
Uemcli -upload -f upgrade
uemcli -d 10.0.0.1 -u joe -p MyPassword456! -upload -f “\\upgrade_image
\ VNXe-upc_BearcatRel_19_202109010410_upcBuilder-upgrade-3.0.0.2643839-3.1.16.10217556-GNOSIS_RETAIL.tgz.bin.gpg” upgrade
注意:在某些陣列上,此步驟會發生問題。
3. 升級:
建立升級工作階段:
Uemcli /sys/soft/upgrade create –candId
uemcli -d 10.0.0.1 -u joe -p MyPassword456! /sys/soft/upgrade create –
candId CAND_1
注意:在 Unisphere GUI 中,此步驟未發現任何問題。
4. 檢視升級工作階段:
Uemcli /sys/soft/upgrade show
uemcli -d 10.0.0.1 -u joe -p MyPassword456! /sys/soft/upgrade show
注意: 在 Unisphere GUI 中,此步驟未發現任何問題。
Affected Products
VNXe1600, VNXe2 Series