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Dell EMC VxRail Troubleshooting Guide for a VMware ESXi hosts in "Not Responding" State

Summary: This article provides solutions to issues with virtual machines residing on a “Not Responding” ESXi host and helps return the ESXi host to a stable state.

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Article Content


Symptoms

  • ESXi host reported as "Not Responding" on vSphere Web Client.
  • Unable to manage ESXi hosts from a vSphere Web Client.
  • Able to ping the "Not Responding" ESXi host and the virtual machines on it.
  • Able to access the virtual machines through SSH/RDP running on the ESXi host.

Cause

One of the management services on the host might have failed or gone into a "Not responding" state.

This requires root cause analysis about why the management services failed or stopped responding. Collect the vCenter Server, and the ESXi host logs by referencing Collecting diagnostic information for VMware ESXi before bringing the cluster/ESXi to a stable state. Sometimes it is impossible as the node will not respond to the commands to collect logs. Review the information in the Resolution section of this article. Logs can be analyzed by DELL EMC support if necessary to understand the root cause to check if the below known issues are related to the issue.

Resolution

Restarting hostd or vpxa on the host could help bring back the host manageability on the vSphere Client. This can be done using an SSH session to the ESXi host.
One other response to a "Not Responding" ESXi host is by restarting the Management agents on the ESXi hosts. (See VMware KB - 1003490)

Restarting the Management agent of an ESXi host could be done directly using a CLI/SSH session to the ESXi (if SSH is enabled prior to the issue). 
However, if SSH is not enabled, accessing the BMC/iDRAC Port would give access to the ESXi DCUI Screen where the management services can be restarted.
See to VMware KB - 1003490 for Restarting the Management agents in ESXi.

If the DCUI console interface is stopped responding and you are unable to restart managements agents or services, manual shutdown of the virtual machines (registered on that node but showing disconnected on vCenter) using SSH or RDP is the only other way around to bring back the Virtual Machines and the ESXi host to a stable state. Once done, using BMC/iDRAC Power Control, Power Cycle (reboot) the ESXi host to get the ESXi host to a stable state.

You can reduce the downtime for the virtual machines prior to rebooting the "Not Responding" ESXi host. Register the Virtual Machines to other stable hosts right after shutting down the Virtual Machines. (After which the issue ESXi host can be rebooted).
Here are steps on How to register or add a Virtual Machine (VM) to the vSphere Inventory in vCenter Server.

If unable to power off the virtual machines using SSH/RDP, terminate a virtual machine through the ESXi host SSH session refer to Unable to Power off a Virtual Machine in an ESXi host. 


Virtual machine issues: 

Unable to power off the virtual machine in an ESXi host - 1014165

Powering off an unresponsive virtual machine on an ESXi host - 1004340

Virtual machines appear as invalid or orphaned in vCenter Server -  1003742

Virtual machines appear to be running or registered on multiple ESX/ESXi Servers - 1005051

Running virtual machine is inaccessible and has missing configuration files - 2006648

Virtual machines are orphaned after rebooting the ESXi host on which they reside - 2013301

Powering on a virtual machine from the command line when the host cannot be managed using vSphere Client - 1038043

Unable to power on an ESX/ESXi virtual machine that previously worked - 1003648

Troubleshooting a virtual machine that has stopped responding - 1007819

Cannot power on a hosted virtual machine - 1003671
 

Virtual machine file related issues: 

Rebuilding the virtual machine's .vmx file from vmware.log - 1023880

Investigating virtual machine file locks on ESXi - 10051

Verifying ESX/ESXi virtual machine file integrity - 1003743

Article Properties


Affected Product

VxRail, VxRail Appliance Family, VxRail Appliance Series, VxRail Software

Last Published Date

13 Oct 2022

Version

3

Article Type

Solution