Symptoms
If going through the Initial Configuration Wizard (ICW) using the service port, you may see a message saying Loading.... on the Cluster Details step which continues for a time. Eventually the User interface (UI) may display:
The required appliance was not found or Request timed out.
This stops the ICW and initialization of the system.
The PowerStore Manager user interface (UI) is not accessible (users cannot log in) after a Nondisruptive Upgrade (NDU) or node reboot.
Attempting to log in fails with error:
"Service unavailable. Please retry in a few minutes. (0xE04040010004)"
Cause
Both the UI and the ICW rely on the management discovery service.
The discovery service relies on Avahi autoipd, which binds a 169.254.x.x/16 IP to local the disc0 interface as local link.
Avahi autoipd may fail to bind the IP to disc0, causing the discovery service to fail.
To check if there is a missing IPv4 169.254.x.x/16 IP bonded on disc0, run this from both nodes:
[SVC:service@XXXXXXX-A/B user]$ ip a show | grep disc0 -A 5 |
Resolution
Upgrade to PowerStore version 2.x or greater which has a fix for the issue discussed in this article.
If you see this issue, contact
Technical Support or your Authorized Service Representative, and quote this knowledge base article ID.
Affected Products
PowerStore