Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Data Protection Advisor: Der Agent kann sich mit dem Fehler „HTTP response code is 403“ nicht registrieren

Summary: Data Protection Advisor Agent unter Windows kann sich aufgrund des Fehlers „HTTP-Antwortcode 403“ nicht beim Anwendungsserver registrieren

This article applies to   This article does not apply to 

Symptoms

Der Agent kann sich nicht beim DPA-Anwendungsserver registrieren, auch nachdem überprüft wurde, dass das Agent-Kennwort richtig ist. Versetzen Sie den Agent in Debug Low, indem Sie die Konfigurationsdatei ändern.
  1. Beenden Sie den Agent.
  2. Erstellen Sie eine Kopie von dpaagent_config.xml
(\emc\dpa\agent\etc\dpaagent_config.xml)
  1. Bearbeiten Sie dpaagent_config.xml und legen Sie die Protokollierungsebene von „Info“ auf „Debug Low“ fest:
Debug Low
  1. Speichern Sie die Datei.
  2. Starten Sie den Agent.
Im Agent-Protokoll ist Folgendes zu finden:     
DBG2 6836.7608 20210310:140114 agent.config - registerAgentProcess(): HTTP response code is 403
ERR  6836.7608 20210310:140114 agent.config - registerAgentProcess(): No response data
ERR  6836.7608 20210310:140114 agent.config - initAgentConfig(): Failed to register agent 

Cause

Der Client-Fehlercode und Antwortcode „Http 403 Forbidden“ gibt an, dass der Server die Anfrage verstanden hat, aber die Autorisierung verweigert.

Im Windows-Betriebssystem ist ein Internetproxy konfiguriert.

Führen Sie auf dem Host den folgenden Befehl aus, um zu überprüfen, ob ein Proxy konfiguriert ist:      
c:\> netsh winhttp show proxy
Aktuelle WinHTTP-Proxyeinstellungen:
Proxyserver: proxy.customerdomain.com:8080

Resolution

  1. Entfernen Sie die Proxy-Konfiguration:      
c:\> netsh winhttp reset proxy
  1. Starten Sie den DPA-Agent neu.      
  2. Bestätigen Sie, dass der Agent registriert wurde, indem Sie dpaagent.log überprüfen:
INFO 6836.7608 20210310:150114  agent.config - initAgentConfig(): Agent hat sich erfolgreich beim Server registriert

Er sollte jetzt in der GUI unter Data Collection > Agents angezeigt werden.
Denken Sie daran, die Agent-Protokollierungsebene auf Info zurückzusetzen.
 
Wenden Sie sich für weitere Informationen an den technischen Support von Dell.

Affected Products

Data Protection, Data Protection Suite, Data Protection Advisor
Article Properties
Article Number: 000184051
Article Type: Solution
Last Modified: 01 Feb 2022
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.
Article Properties
Article Number: 000184051
Article Type: Solution
Last Modified: 01 Feb 2022
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.