Symptoms
Jobmonitor failing for Data Protector server with timeout, backup data is not being collected by DPA.
The dpaagent log contains the following error:
ERR 9425.9447 20210129:095944 agent.mod.dp - dpRunCmd(): timeout running omnicellinfo against server 'DP_server_hostname'
The History of the jobmonitor request for that Data Protector server typically shows the following:
![image.png](https://supportkb.dell.com/img/ka02R000000LYsyQAG/ka02R000000LYsyQAG_en_US_1.jpeg)
.
Cause
The current design of the Data Protector module in DPA is to run the omnicellinfo command multiple times during data collection.
It tries to run omnicellinfo once for each client that ran a backup during the polling period of the request.
If the command takes more than 30-60 seconds to run, then it takes a very long time if for example 100 clients ran a backup within that polling timeframe.
Resolution
On the Data Protector server, run the following command and observe how long it takes:
> omnicellinfo -server <server hostname> -cell brief
If the command takes longer than 1 minute (ideally it should run under 30 seconds for optimal performance), then Micro Focus should be engaged to reduce the time it takes for omnicellinfo to run.
Contact Dell Technical Support for further information.