Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

PowerFlex: 게이트웨이에서 get_info 로그 수집이 오류와 함께 실패함 다음 오류가 발생합니다. 노드 x.x.x.x의 로그 파일을 찾을 수 없습니다. LogCollection명령

Summary: /tmp가 상주하는 파일 시스템이 ftype=0으로 생성되면 게이트웨이에서 get_info 로그 수집이 실패함

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

게이트웨이에서 Getinfo 로그 수집이 실패하고 아래 오류가 표시됩니다.

* 게이트웨이에서 scaleio.log *

[집행자-4] INFO c.e.s.s.i.s.i.c.LIANodeConnection - UnknownSystemNode[nodeName=4640301440918548081,nodeIPs=[192.168.180.x, 192.168.190.x],credentials=<null>]에서 downloadInfo가 호출되었습니다.
[집행자-4] INFO c.e.s.s.i.s.i.c.LIANodeConnection - getLogFilePathByUniqueFlowId가 UnknownSystemNode[nodeName=4640301440918548081,nodeIPs=[192.168.180.x, 192.168.190.x],credentials=<null>]에서 호출되었습니다. uniqueFlowId: getInfoDump
[executor-4] ERROR c.e.s.d.i.c.LogCollectionCommand - 오류 노드 192.168.180.x, 192.168.190.x의 로그 파일을 찾을 수 없습니다. LogCollectionCommand(재시도): com.emc.s3g.scaleio.im.services.installation.connectors.LIANodeConnection.getLogs(LIANodeConnection.java:1850)    
com.emc.s3g.scaleio.im.services.installation.connectors.LIANodeConnection.downloadInfo(LIANodeConnection.java:1522)    


get_info 로그 수집이 실패한 ScaleIO 노드에 로그인합니다.
추적 로그에서 LIA는 디렉토리 아래의 관련 파일을 찾을 수 없습니다. getinfo 파일이 생성되었지만.

# ls -l
합계 50508
-Rw-------. 1 루트 루트 51717813 Oct 16 03:57 getInfoDump.tgz
# 날짜
금 Oct 16 03:57:01 CDT 2020

* LIA 폴더 또는 노드 192.168.180.x의 /opt/emc/scaleio/lia/logs/trc.0 로그 **
7f17ac10bdb0:liaNet_RecvRequest:00351: 마지막 로그인 이후 10분
7f17ac10bdb0:liaNet_RecvRequest:01112: 로그 파일 가져오기 시작
7f17ac10bdb0:liaCmd_GetLogFilesHelper:01239: 파일 수: 0 <<<-----------
7f17ac10bdb0:liaNet_RecvRequest:01145: 로그 파일 가져오기 종료

Cause

Lia 코드는 컬렉션의 일부로 생성된 getInfoDump.tgz를 찾기 위해 "디렉토리 항목"을 사용합니다. LIA는 디렉토리의 내용을 가져오기 위해 "readdir()"이라는 특정 함수를 사용합니다.
LIA가 "readdir ()"을 호출하면 "d_type"필드를 가져올 것으로 예상합니다. 이 필드는 "getInfoDump.tgz"가 일반 파일("DT_REG")인지 여부를 나타냅니다.
모든 파일 시스템이 d_type

지원하는 것은 아닙니다. 생성된 파일 시스템이 "d_type"를 지원하지 않는 경우 "readdir()" 함수가 호출되면 반환되는 값은 다음과 같습니다. "DT_UNKNOWN"와 LIA는 디렉토리에서 0 개의 파일을 찾습니다.

XFS 파일 시스템을 생성한 경우 아래 명령을 실행하여 ftype을 확인하십시오.

Resolution

이 문제는 PowerFlex v3.6에서 해결되었습니다.
 
해결 방법
/tmp가 상주하는 곳에서 생성된 파일 시스템이 Btrfs, ext2, ext3 및 ext4여야 합니다.
XFS 파일 시스템의 경우 파일 시스템이 "ftype=1"로 생성되었는지 확인합니다.

Affected Products

PowerFlex Software, VxFlex Product Family

Products

PowerFlex rack, VxFlex Ready Nodes, VxFlex Product Family, VxFlex Ready Node, VxFlex Ready Node R640, VxFlex Ready Node R740xd
Article Properties
Article Number: 000182487
Article Type: Solution
Last Modified: 11 Jan 2023
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.