Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

No Video from USB Type-C Port on an Alienware or XPS

Summary: Learn about what to do when a USB Type-C port and cable are not providing video output on an Alienware or Dell XPS desktop.

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

A USB Type-C port and cable show no video with affected Alienware and XPS computers.

Affected Platforms:

  • Alienware Area-51 Threadripper Edition R3 and R6
  • Alienware Area-51 R4 and R5
  • Alienware Aurora R6
  • Alienware Aurora R13
  • Alienware Aurora Ryzen Edition R14
  • Alienware Aurora R15
  • Alienware Aurora R16
  • XPS 8950
  • XPS 8960

Cause

The USB Type-C port on affected Alienware and XPS platforms has no video output by design.

Resolution

Article Properties


Affected Product

Alienware Area-51 Threadripper Edition R3 and R6, Alienware Area-51 R4 and R5, Alienware Aurora R13, Alienware Aurora Ryzen Edition R14, Alienware Aurora R15, Alienware Aurora R16, Alienware Aurora R6, XPS 8950, XPS 8960

Last Published Date

24 Jul 2024

Version

5

Article Type

Solution