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So identifizieren Sie ein fehlerhaftes Teil, wenn der Fehler BUS DEVICE FUNCTION auftritt

Summary: Dieser Artikel enthält Informationen zur Identifizierung fehlerhafter Geräte auf PCIe-Bussen in PowerEdge-Servern und zur ordnungsgemäßen Fehlerbehebung. Informationen zur Identifizierung fehlerhafter Geräte auf PCIe-Bussen in PowerEdge-Servern und zur ordnungsgemäßen Fehlerbehebung. Das Busgerät und die Funktion verweisen auf ein bestimmtes Gerät auf dem PCI-Bus. ...

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Article Content


Symptoms


Inhaltsverzeichnis

  1. Fehlermeldung
  2. Möglichkeiten zum Bestimmen von Bus/Gerät/Funktion
  3. Schritte zur Fehlerbehebung

1. Fehlermeldung

Fehlermeldungen zu ausgefallenen Geräten finden Sie im Serverereignisprotokoll (SEL) oder auf der Frontanzeige (LCD, falls vorhanden) von PowerEdge-Servern.
Fehlercodes auf der LCD-Anzeige von PowerEdge-Servern vor Generation 12:
  • E171f
  • E1711
  • E1712

Das Busgerät und die Funktion weisen auf ein bestimmtes Gerät am PCI-Bus hin. Das Gerät kann aus mehreren Gründen fehlerhaft sein. Treiber / Firmware können dazu führen, dass sich ein Gerät unregelmäßig verhält und diese Meldung auslöst. Der offensichtliche andere Grund wäre, dass das Gerät nicht richtig funktioniert. „B# D# F#“ ist die Adresse zum Gerätestandort auf dem PCI-Bus.


2. Möglichkeiten zum Bestimmen von Bus/Gerät/Funktion

a. BUS/Gerät/Funktion befindet sich in einer XML-Datei im DSET-Verzeichnis.

Wenn ein DSET-Bericht auf einem System erstellt wird, finden Sie die Datei binrawxmlslots.xml im Verzeichnis der erstellten Sammlung.

 

SLN78547_en_US__21306506864560.DSET_slot.xml
Abb. 1: Ordner „DSET“

 

Doppelklicken Sie auf die Datei, um Sie in Internet Explorer oder einem anderen Browser zu öffnen. Jedes Gerät wird nach Name aufgelistet und unter jedem Gerätenamen werden und aufgeführt.

SLN78547_en_US__31306507113938.DSET_BUSDEVFUNC
Abb. 2: Geöffnet in IE


b. In Windows Geräte-Manager können Sie die Eigenschaftenfenster überprüfen.

Rufen Sie den Windows-Geräte-Manager auf (nur Windows-Betriebssystem) und klicken Sie mit der rechten Maustaste auf das Gerät, das Sie überprüfen möchten. Klicken Sie auf Eigenschaften und überprüfen Sie den Eintrag unter Standort auf der Registerkarte Allgemein.

 

SLN78547_en_US__41266947466432.1
Abb. 3: Eigenschaftenfenster


c. Überprüfen Sie die Registrierungseinträge.

Der Registrierungsspeicherort lautet „Hklm\system\currentcontrolset\enum\PCI\“. Alle Unterordner müssen angeklickt werden, um die Informationen im rechten Fensterbereich anzuzeigen.

 

SLN78547_en_US__51266947530527.2
Abb. 4: Fenster des Registrierungseditors


Cause

Das Gerät kann aus einigen Gründen fehlerhaft sein. Treiber / Firmware können dazu führen, dass sich ein Gerät unregelmäßig verhält und diese Meldung auslöst. Der offensichtliche andere Grund wäre, dass das Gerät nicht richtig funktioniert.

 

Resolution

3. Schritte zur Fehlerbehebung

Nachdem das ausgefallene Gerät identifiziert wurde, können Sie mit dem Troubleshooting beginnen.

  1. In der Regel sollten alle Firmware des Systems auf dem neuesten Stand sein, bevor Sie mit den nächsten Schritten beginnen. Wir empfehlen die Verwendung einer startfähigen ISO-Datei.
  2. Setzen Sie das Gerät (falls möglich) neu ein und starten Sie es neu. Das SEL sollte vorher gelöscht werden. Andernfalls wird die alte Fehlermeldung erneut angezeigt.
  3. Nehmen Sie das Gerät aus dem System und starten Sie es neu. Das SEL sollte vorher gelöscht werden. Andernfalls wird die alte Fehlermeldung erneut angezeigt.
  4. Testen Sie das Gerät in einem anderen Steckplatz, falls möglich.

Article Properties


Affected Product

Servers

Last Published Date

29 Aug 2023

Version

7

Article Type

Solution