Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

PowerStore Alerts: Projected Running Out of Space Alerts

Summary: An appliance(s) within a PowerStore cluster or the entire cluster is running low on storage space.

This article applies to   This article does not apply to 

Symptoms

When Dell PowerStore encounters a problem, an error alert is generated to help identify the issue. This article explains the different possible causes and the relevant solutions for these error alerts. If your problem is not resolved despite the solution provided, check the technical support contact options.
SLN317192_en_US__1icon Note: Cannot find the information you need? Let us know via the feedback form at the bottom of this article.

Cause

Refer the resolution section for more details.

Resolution

Alert ID RESOURCE_BALANCER_TIME_TO_FULL_CLUSTER_BELOW_MAJOR_THRESHOLD
RESOURCE_BALANCER_TIME_TO_FULL_APPLIANCE_BELOW_MAJOR_THRESHOLD
Alert Text The cluster is projected to run out of space in %(ttf_days) days.
The appliance %(object_id) is projected to run out of space in %(ttf_days) days.
Error Code (0x00A00301) (0x00A00401) 
Description An appliance(s) within a PowerStore cluster or the entire cluster is running low on storage space. The customer is alerted daily until the issue is resolved to avoid running out of storage space entirely. When PowerStore runs out of storage space, it goes into "read-only" mode.
Resolution Cause
Based on predictive analytics, an appliance(s) within a PowerStore cluster or the entire cluster is projected to run out of storage space within 14 days. There are three internal thresholds the system uses to determine when to alert the user:         
  • Major alert: (1 day – 14 days):     Alerts 0x00A00401 and 0x00A00301         
  • Minor alert: (15 days – 28 days): Alerts 0x00A00402 and 0x00A00302         
  • Okay (4+ weeks)
When the system object is projected to run out of storage space in 14 days the user will get a major alert . The system object may be an appliance within a PowerStore cluster or the entire PowerStore cluster. Alerts will continue daily until the issue is resolved.

Solution
When a major alert is raised for an appliance that is predicted to run out of space, the alert details dialog window guides the user through a repair workflow.
alert details dialog window
 
The PowerStore Manager Repair Flow offers the following options:       
  • Assisted Migration. The system recommends where storage should be migrated within the cluster.         
  • Add more Drives. The user is guided to the General Support page for assistance.         
  • Consider deleting unused snapshots or volumes.
Alternatively, the migration recommendation REST APIs can be used if Assisted Migration is desired using the REST API (/api/rest/migration_recommendation). Refer to the REST API Reference Guide for PowerStore in PowerStore Info Hub for additional information.
 
When a major alert is raised for a cluster that is predicted to run out of space, one of the following actions can be performed:
  • add more drives
  • add an expansion enclosure
  • delete unused snapshots or volumes
 
 
Alert ID RESOURCE_BALANCER_TIME_TO_FULL_APPLIANCE_BELOW_MINOR_THRESHOLD
RESOURCE_BALANCER_TIME_TO_FULL_CLUSTER_BELOW_MINOR_THRESHOLD
Alert Text Appliance %(object_id) is projected to run out of space in %(ttf_days) days.
The cluster is projected to run out of space in %(ttf_days) days.
Error Code (0x00A00302) (0x00A00402)
Description An appliance(s) within a PowerStore cluster or the entire cluster is running low on storage space. The customer is alerted daily until the issue is resolved to avoid running out of storage space entirely. When PowerStore runs out of storage space, it goes into "read-only" mode.
Resolution Cause
Based on predictive analytics, an appliance(s) within a PowerStore cluster or the entire cluster is projected to run out of storage space within 28 days. There are three internal thresholds the system uses to determine when to alert the user:         
  • Major alert: (1 day – 14 days):  Alerts 0x00A00401 and 0x00A00301         
  • Minor alert: (15 days – 28 days): Alerts 0x00A00402 and 0x00A00302
  • Okay (4+ weeks)
When the system object is projected to run out of storage space in 28 days the user will get a minor alert . The system object may be an appliance within a PowerStore cluster or the entire PowerStore cluster. Alerts will continue daily until the issue is resolved.

Solution
When a minor alert is raised that a cluster or appliance is predicted to run out of space, consider one of the following:
  • migrate volumes from one appliance to another. Only applicable for appliance alerts, e,g, 0x00A00302.
  • add more drives
  • add an expansion enclosure
  • delete unused snapshots or volumes.
 
 
Alert ID RESOURCE_BALANCER_DISK_HIGH_WEAR_RATE_APPLIANCE_ABOVE_THRESHOLD
Alert Text System drives are experiencing high wear rates (more than 4% in 60 days)
Error Code 0x00A00601
Impact Drive will be used until the drive fails or endurance is exhausted.
Resolution  Solution:
Contact Technical Support as soon as possible for assistance in resolving this issue.
 

Affected Products

PowerStore
Article Properties
Article Number: 000131197
Article Type: Solution
Last Modified: 30 May 2024
Version:  7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.