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PowerStore Alerts: Cabling, Native VLAN, Ping Unreachable, and ToR Port Config and Speed Alerts

Summary: This article discusses the alerts related to Cabling, Native VLAN, Ping Unreachable, and ToR Port Config and Speed Alerts.

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Article Content


Symptoms

When Dell PowerStore encounters an issue, an error alert is generated to help identify the issue. This article explains the different possible causes and the remediation for these error alerts. If your issue is not resolved despite the solution provided, check the technical support contact options.
 
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Cause

Cause is explained in Resolution section for respective Alerts.

Resolution

Alert ID
  1. ONV_NODE_MGMT_PORT_CABLING_STATE_MGMT_PORT_IN_TOR_SWITCH
  2. ONV_NODE_DATA_PORTS_CABLING_STATE_DATA_PORT_IN_MGMT_SWITCH
  3. ONV_APPLIANCE_CABLING_PARTNER_PORTS_REDUNDANCY_STATE_SAME_TOR_SWITCHES_FOR_PORTS
  4. ONV_NODE_CABLING_ORDER_STATE_INVALID
Alert Text
  1. Onboard management port is connected to the data network switch %(physical_switch_id).
  2. Data ports are connected to the dedicated management switch: %(connection_scheme).
  3. Appliance port pairs are connected to the same data switch: %(connection_scheme).
  4. Order of node port cabling to the data switches is not correct: %(connection_scheme).
Error Code
  1. (0x01800702)
  2. (0x01800802)
  3. (0x01800b02)
  4. (0x01800a02)
Impact
  1. Management traffic is not separate from data traffic on switch.
  2. Performance or connectivity may be degraded or limited.
  3. A single switch failure may cause data unavailability.
  4. Performance may be degraded.
Resolution Cause
These alerts are triggered when the PowerStore Ethernet cables are not plugged into the ToR switches following recommended pattern.
If any of the alerts mentioned above are active, there is a strong possibility that any cable, port or switch failure may disrupt the I/O or the management connection. The user should keep the cable connections confirming to the recommended pattern.

The Data/Management ports of a PowerStore appliance should be connected to ToR switches in the specific manner. Three requirements should be met:
  • The management ports and the 4-Port card ports must be connected to the different ToR switches
  • Port 0 on Node A and Port 0 on Node B must be connected to different ToR switches
  • Port 0 and port 1 on each node needs to be connected to different switches
Remediation
  1. ONV_NODE_MGMT_PORT_CABLING_STATE_MGMT_PORT_IN_TOR_SWITCH.
    • The onboard management port needs to be connected to the dedicated management switch.
  2. ONV_NODE_DATA_PORTS_CABLING_STATE_DATA_PORT_IN_MGMT_SWITCH
    • Check cabling of the node and connect these ports to the data switches.
  3. ONV_APPLIANCE_CABLING_PARTNER_PORTS_REDUNDANCY_STATE_SAME_TOR_SWITCHES_FOR_PORTS
    • Check the cabling of the appliance to ensure that data ports of each node are connected to different data switches to avoid a single point of failure.
  4. ONV_NODE_CABLING_ORDER_STATE_INVALID
    • Check cabling of the node to ensure that the ports are connected to different data switches according to the recommended configuration.
Refer to Dell EMC PowerStore Network Planning Guide for instructions on connectivity.
 

 

Alert ID
  1. ONV_PORT_NATIVE_VLAN_STATE_INCONSISTENT
  2. ONV_APPLIANCE_MGMT_PORTS_NATIVE_VLAN_STATE_INVALID
  3. ONV_APPLIANCE_DATA_PORTS_NATIVE_VLAN_STATE_INVALID
  4. ONV_CLUSTER_MGMT_PORTS_NATIVE_VLAN_STATE_INVALID
  5. ONV_CLUSTER_DATA_PORTS_NATIVE_VLAN_STATE_INVALID
Alert Text
  1. Native VLAN information is not consistent for %(local_port).
  2. Native VLAN mismatch detected between management switch ports: %(connection_scheme).
  3. Native VLAN mismatch detected between data switch ports: %(connection_scheme).
  4. Cluster-wide native VLAN mismatch detected between management switch ports: %(connection_scheme).
  5. Cluster-wide native VLAN mismatch detected between data switch ports: %(connection_scheme).
Error Code
  1. (0x01801b02)
  2. (0x01801d02)
  3. (0x01801c02)
  4. (0x01806b02)
  5. (0x01806a02)
Impact
  1. No impact.
  2. Management connectivity may be impacted.
  3. Inconsistent native VLAN settings can lead to internal connectivity issues.
  4. Management connectivity may be degraded.
  5. Appliance connectivity may be degraded.
Resolution Cause
The different method native VLAN mismatch could be caused by a miscommunication between the ToR switch and the PowerStore. It could be a result of the firmware update to the version not fully supported by the PowerStore verification routines, or by a bug in the switch firmware.
The native VLAN mismatch on the data or management ports is a result of the ToR switch misconfiguration.
The PowerStore may detect one of the two native VLAN inconsistencies:
  • The native VLAN IDs assigned to the same Data/Management ToR switch port but reported by different methods do not match.
  • The native VLAN IDs assigned to the different Data/Management ToR switch ports do not match for the data or for the management ports, in the appliance scope or in the cluster scope
A.  If the native VLAN IDs reported by the different methods are not the same, the system shows an alert like this: 
Native VLAN information is not consistent for <node and port ID>.
This alert is shown for each port individually.

B.  If the native VLAN IDs reported for the different ports are not the same, the system shows an alert like one of these:
Cluster-wide native VLAN mismatch detected between management switch ports: <connection_scheme>.
Cluster-wide native VLAN mismatch detected between data switch ports: <connection_scheme>.

These alerts are shown one for each port type and scope, listing all the corresponding ports. PowerStore has no means to detect which of the reported native VLAN ID should be considered correct. For that reason, it lists all the ports giving user the full information to decide which setting need to be corrected.

Remediation
  1. ONV_PORT_NATIVE_VLAN_STATE_INCONSISTENT
    • Check your switch configuration to ensure that native VLAN information is consistent across the protocols.
  2. ONV_APPLIANCE_MGMT_PORTS_NATIVE_VLAN_STATE_INVALID
    • Ensure that the native VLAN is configured consistently on the displayed management switch ports.
  3. ONV_APPLIANCE_DATA_PORTS_NATIVE_VLAN_STATE_INVALID
    • Ensure that the native VLAN is configured consistently on the displayed data switch ports.
  4. ONV_CLUSTER_MGMT_PORTS_NATIVE_VLAN_STATE_INVALID
    • Ensure that the native VLAN is configured consistently on the displayed management switch ports.
  5. ONV_CLUSTER_DATA_PORTS_NATIVE_VLAN_STATE_INVALID
    • Ensure that the native VLAN is configured consistently on the displayed data switch ports.
 

 

Alert ID
  1. ONV_ICC_ICM_PING_STATUS_UNREACHABLE
  2. ONV_ICC_ICD_PING_STATUS_UNREACHABLE
  3. ONV_ICC_MGMT_PING_STATUS_UNREACHABLE
  4. ONV_ICC_STORAGE_PING_STATUS_UNREACHABLE
  5. ONV_ICC_VMOTION_PING_STATUS_UNREACHABLE
Alert Text The following <network name> network addresses are not reachable via ICMP from node network interfaces: (from <IP address> : <IP address>), …
Error Code
  1. (0x01802f02)
  2. (0x01803102)
  3. (0x01802b02)
  4. (0x01802d02)
  5. (0x01803302)
Resolution Cause
These alerts are shown when the PowerStore has detected that certain IP addresses of the cluster stopped responding to the ping requests (ICMP or ICMPv6 echo requests) from other IP addresses of the same cluster.
This check is performed in each network, on the "any to any" basis. If any IP address does not respond to ping from any other IP address of the same network, an alert is shown.
The loss of connectivity can be caused by several reasons. It happens when an appliance is powered off, network cables got disconnected, or some other network infrastructure issues happens.

Remediation
Check the hardware health status, the port link status and look for the general infrastructure issues. Fix the root cause.
 

 

Alert ID
  1. ONV_PORT_MODE_CONFIG_STATE_INVALID
  2. ONV_PORT_STP_MODE_CONFIG_STATE_INVALID
  3. ONV_PORT_TOR_ALLOWED_VLANS_STATE_INVALID
  4. ONV_PORT_LLDP_ALLOWED_VLANS_STATE_INVALID
Alert Text
  1. Port <physical_switch_port_id> on switch <physical_switch_id> is not configured in trunk/hybrid mode.
  2. STP on port <physical_switch_port_id> of switch <physical_switch_id> is not configured in PortFast/EdgePort mode.
  3. The <local_port> has no access to VLANs <missed_vlans> because it is connected to port <physical_switch_port_id> of switch <physical_switch_id> with allowed VLANs <allowed_vlans> according to switch information received via SSH / SNMP.
  4. The <local_port> has no access to VLANs <missed_vlans> because it is connected to port <physical_switch_port_id> of switch <physical_switch_id> with allowed VLANs <allowed_vlans> according to information received via Link Layer Discovery Protocol (LLDP).
Error Code
  1. (0x01802702)
  2. (0x01802802)
  3. (0x01801e02)
  4. (0x01801f02)
Impact Network connectivity/performance may be impacted.
Resolution Cause
These alerts are caused by the Switch misconfiguration or the PowerStore VLAN misconfiguration.
  • The PowerStore requires that the Switch ports to which it is connected are configured the following way:
  • The ports should be configured in the trunk or hybrid mode to allow both native and tagged traffic from the PowerStore.
  • The ports should be configured to be the edge ports for the STP protocol. No STP negotiating should be attempted on the PowerStore facing ports.
  • The ports should allow the tagged traffic in the VLANs which PowerStore is configured to use.
PowerStore uses both the ToR switch management access and the LLDP protocol to get the ToR switch ports configuration information. Hence alerts are triggered if the reported port configuration does not meet the requirements named above. These alerts are shown for each port individually.

Remediation
  1. ONV_PORT_MODE_CONFIG_STATE_INVALID
    • Configure the port in trunk/hybrid mode to allow VLAN-tagged traffic.
  2. ONV_PORT_STP_MODE_CONFIG_STATE_INVALID
    • Configure STP on the port in PortFast/EdgePort mode to avoid STP convergence delays.
  3. ONV_PORT_TOR_ALLOWED_VLANS_STATE_INVALID
    • Check the allowed VLANs settings on port <physical_switch_port_id> of the switch <physical_switch_id> and add VLAN(s) <missed_vlans> to the list of allowed VLANs.
  4. ONV_PORT_LLDP_ALLOWED_VLANS_STATE_INVALID
    • Check the allowed VLANs settings on port <physical_switch_port_id> of the switch <physical_switch_id> and add VLAN(s) <missed_vlans> to the list of allowed VLANs.
 

 

Alert ID
  1. ONV_PORT_TOR_SPEED_STATE_INVALID
  2. ONV_PORT_LOCAL_SPEED_STATE_INVALID
  3. ONV_PORT_SPEED_CONSISTENCY_STATE_INCONSISTENT
  4. ONV_NODE_DATA_PORTS_SPEED_STATE_INVALID
  5. ONV_APPLIANCE_MGMT_PORTS_SPEED_STATE_INVALID
  6. ONV_APPLIANCE_DATA_PORTS_SPEED_STATE_INVALID
Alert Text
  1. The <port_speed_status>, but the system requires at least <required_speed> Gbps ports.
  2. The <port_speed_status>, but the system requires at least <required_speed> Gbps ports.
  3. Speed information is not consistent for <local_port> with the switch port.
  4. Speed mismatch detected: <connection_scheme>.
  5. Speed configuration is not consistent: <connection_scheme>.
  6. Speed configuration is not consistent: <connection_scheme)>.
Error Code
  1. (0x01802102)
  2. (0x01802002)
  3. (0x01802202)
  4. (0x01806902)
  5. (0x01802302)
  6. (0x01802402)
Impact Network performance may be impacted.
Resolution Cause
These alerts are shown when the PowerStore detects on its data/management ports one of the following conditions:
  • The speed settings of the PowerStore port or the switch port it is connected to, are lower than the minimal required speed. The minimal required speed is 1 Gbit/s for the management port and 10 Gbit/s for the data ports.
    The management port is the 1Gbit OOB management port of the -T models. The data ports are all other ports on both -T and -X models.
  • The speed settings of the PowerStore port and the switch port it is connected to, are not the same.
  • The speed settings of the PowerStore management ports or the switch ports they are connected to, are not the same on the same node.
  • The speed settings of the PowerStore data ports or the switch ports they are connected to, are not the same on the same node.
  • The speed settings of the PowerStore ports or the switch ports they are connected to, are not the same for the partner ports.
The partner ports are the same ports of the two nodes of the same appliance. For example, the second port of the 4-Port card of node N1 and the second port of the 4-Port card of node N2 of the same appliance are the partner ports.
The common root cause is the ToR data/management switch misconfiguration. The administrator may be explicitly set up the low speed on the ports to be used by PowerStore, or the SFP transceivers used at the switch side cannot support the full speed of the link. It could be possible that the speed is manually set to an incorrect value on the PowerStore side too.
Normally the speed is auto-negotiated between PowerStore and the switch to the maximum mutually supported speed. If some of the data links in the cluster support 25 Gbit/s while other do not, it might be necessary to manually set the speed to of these links to 10 Gbit/s.
The requirements to have the same speed set on the ports of the same kind of the same appliance are important to ensure the correct operation of the automatic failover procedures.

Remediation
  1. ONV_PORT_TOR_SPEED_STATE_INVALID
    • Ensure that the speed is correctly configured on the switch ports.
  2. ONV_PORT_LOCAL_SPEED_STATE_INVALID
    • Ensure that the speed is correctly configured on the switch ports.
  3. ONV_PORT_SPEED_CONSISTENCY_STATE_INCONSISTENT
    • Ensure that the speed is correctly configured on the switch ports.
  4. ONV_NODE_DATA_PORTS_SPEED_STATE_INVALID
    • Ensure that the speed is configured consistently on the data switch ports.
  5. ONV_APPLIANCE_MGMT_PORTS_SPEED_STATE_INVALID
    • Ensure that the speed is configured consistently on the management switch ports.
  6. ONV_APPLIANCE_DATA_PORTS_SPEED_STATE_INVALID
    • Ensure that the speed is configured consistently on the data switch ports.

Note: Check the ToR data/management switch configuration, both software and hardware. Make sure that the management connections support at least 1Gbit/s and the data connections at least 10 Gbit/s. Make sure that all the management and all the data connections in the cluster scope are set to the same speeds.
 

 

Alert ID ONV_ICC_ICD_PING_STATUS_BLOCKING_UNREACHABLE
Alert Text The following intra-cluster data network addresses are not reachable via ICMP from node network interfaces: %(ping_scheme).
Error Code (0x01803103)
Impact Software upgrade on NAS-enabled appliances may fail. Migration of resources across the cluster may be impacted. User may be unable to perform software upgrades.
Resolution  Cause
This issue is caused when intra-cluster data network addresses are not reachable via ICMP from node network interfaces.

Remediation
Check the cabling and VLAN configuration within the cluster nodes and data/management switches.
 
 
Alert ID ONV_PORT_LOCAL_SPEED_STATE_TOO_LOW
Alert Text Port %(port_id) speed is less than %(lowest_possible_speed) Gbps, but the system requires at least %(required_speed) Gbps ports.
Error Code (0x01802003)
Impact Network performance may be impacted when the local port speed is less than the system requirement.
Resolution Cause
This issue is caused when current port local speed configuration is too low.

Remediation
Ensure that the speed is correctly configured on the switch port.
 
 
Alert ID ONV_PORT_TOR_SPEED_STATE_TOO_LOW
Alert Text Port %(port_id) of switch %(physical_switch_id) has a speed which is less than %(lowest_possible_speed) Gbps, but the system requires at least %(required_speed) Gbps ports.
Error Code (0x01802103)
Impact Network performance may be impacted when the switch port speed is less than the system requirement.
Resolution  Cause
This issue is caused when speed configuration on the switch port connected to the local port is too low.

Remediation
Ensure that the speed is correctly configured on the switch port.
 
 
Alert ID ONV_PORT_TOR_SPEED_STATE_INCORRECT
Alert Text The %(port_speed_status), but the system requires at least %(required_speed) Gbps ports.
Error Code (0x01802104)
Impact Network performance may be impacted when the switch port speed is less than the system requirement.
Resolution Cause
This issue is caused when current state of speed configuration on the Etherrnet switch port connected to the local port is incorrect.

Remediation
Ensure that the speed is correctly configured on the switch port.
 

Article Properties


Affected Product

PowerStore

Last Published Date

06 Dec 2021

Version

8

Article Type

Solution