Symptoms
When the PowerStore encounters an issue, an error alert is generated to help identify the issue.
This article explains the different possible causes and the relevant solutions for these error alerts.
If your issue is not resolved despite the solution that is provided, check the technical
support contact options.
Cause
Cause is described in the resolution section for respective alerts.
For an explanation of how Physical Capacity is calculated, see KB article188491:
PowerStore: How PowerStore Physical Capacity is calculated.
Resolution
Alert Text |
The capacity utilization of appliance's system data is above 90 percent. The capacity utilization of appliance's system data is above 95 percent. The appliance's system data has reached full capacity. |
Error Code |
(0x00201601) (0x00201604) (0x00201602) |
Alert ID |
DATA_PATH_SYSTEM_DATA_CAPACITY_UTILIZATION_ABOVE_90_PERCENT DATA_PATH_SYSTEM_DATA_CAPACITY_UTILIZATION_ABOVE_95_PERCENT DATA_PATH_SYSTEM_DATA_CAPACITY_UTILIZATION_100_PERCENT |
Resolution |
Cause PowerStore appliance requires space for its internal system data. The system preallocates space upon initialization, and expands system space as required. User space is allocated by demand. The space used to expand System or User Data is known as Expandable Capacity (capacity which can be used to expand either System or User Data). User Data space can expand and shrink (meaning capacity that is released from User Data may be repurposed for System Data). However, System Data space can only expand, it cannot shrink. So for example, you may have a PowerStore with 100 TB allocated for user data, however it may only be using 60 TB of that space and 40 TB can be repurposed for either User Data or System Data. The Appliance triggers:
- 0x00201601 alert when the expandable capacity for System Data is 10% of the total space of the system.
- 0x00201604 alert when the expandable capacity for System Data is 5% of the total space of the system.
- 0x00201602 alert when the expandable capacity for System Data is 0% of the total space of the system.
Note: The thresholds may change in a future release. Example: The example is a high-level description of how the alerts work. A PowerStore was configured with a 100 TB total physical capacity appliance. At some point in time:
- User Data is allocated at 80 TB, but only 60 TB is in use.
This means we have the potential of releasing 20 TB (if needed) from User Data space to System Data Space.
- System Data Space was allocated 10 TB of space.
This space cannot be reclaimed unless snapshots or deduplicated user data are deleted, and cannot be repurposed for User Data Space (this space can only be used by System Data).
- The UI shows 70% (60 TB used by the user and 10 TB used for System Data).
The UI provides a breakdown between user data and system data.
- This means that the system has around 10 TB of expandable capacity (100 TB(Total) - 80 TB (User) - 10 TB (System) = 10 TB)
- 10 TB (left for expansion) out of 100 TB is 10%, and so an 0x00201601 alert is raised.
- However, the Appliance can still leverage free space from the User Data (~ 20 TB) to continue expanding, so the alert may be misleading under some scenarios.
Solution
If you receive any of the above alerts, examine first the Total Physical Capacity Used as shown in the PowerStore UI under Capacity Dashboard.
In the example below, the Appliance has 1.5% Total Physical Capacity used:
Use the below table as guidelines for handling this alert:
Total Physical Capacity Used |
Alert 0x00201601 Raised (90%) |
Alert 0x00201604 Raised (95%) |
Alert 0x00201602 Raised (100%) |
Less than 80% |
No Action Needed |
No Action Needed |
See guidelines below |
Above 80% |
No Action Needed |
See guidelines below |
See guidelines below |
Above 90% |
See guidelines below |
See guidelines below |
See guidelines below |
Guidelines
- The system administrator should consider deleting snapshots, reducing the number of snapshots scheduled, deleting data, or adding drives.
- The Appliance should still be operational, and no impact to Data Access, however there is a risk that the appliance may enter Write Protect Mode at this rate due to System Data not having sufficient space to expand (note that the UI may show ample amount of physical space).
- It is highly recommended for the system administrator to approach their local account team to examine the system and decide on proper sizing for the system.
- If you are in doubt, escalate to Technical Support for assistance.
- A Dial Home is sent to Dell EMC if the cluster is connected to SupportAssist.
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Affected Products
PowerStore