Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

NetWorker: Klientovi Solaris NetWorker se nepodařilo zálohovat s chybou "Cannot bind socket to connection port"

Summary: Připojovací porty: 10001-30000 umožňuje démonům udržovat připojení na hostiteli Solaris, když zálohy hlásí "Nelze svázat soket s portem připojení v nakonfigurovaném rozsahu portů v systému". : Nelze přiřadit požadovanou adresu. ...

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

  • Plánovaná záloha hostitele Solaris občas hlásí:
61320:savefs: Cannot bind socket to connection port in configured port range on system <Client_name>: Cannot assign requested address
61320:savefs: Cannot bind socket to connection port in configured port range on system <Client_name>: Cannot assign requested address
97512:savefs: Cannot access NetWorker server '<NetWorker_server_name>': Remote system error - Cannot assign requested address
savefs <Client_name>: failed.

 

  • Soubor daemon.raw v klientských sestavách:
61320 1483533202 3 1 126 3 38646 0 <Client_name> nsrexecd SYSTEM error 79 Cannot bind socket to connection port in configured port range on system %s: %s 2 12 10 <Client_name> 24 31 Cannot assign requested address - Port is free

NetWorker: Návod k použití nsr_render_log

 

  • Příkaz netstat na klientovi má CLOSE_WAIT pro 7937 a 7938.
root@<Client_Name> # netstat -an | grep -i 7938
<ip_address_1>.37938 <ip_address_1>.9151 49878 0 49152 0 CLOSE_WAIT
<ip_address_1>.47938 <ip_address_1>.9151 49877 0 49152 0 CLOSE_WAIT
<ip_address_1>.57938 <ip_address_1>.9151 49877 0 49152 0 CLOSE_WAIT
 
root@fmsprochk1 # netstat -an | grep -i 7937
<ip_address_1>.37937 <ip_address_1>.9151 49875 0 49152 0 CLOSE_WAIT
<ip_address_1>.57937 <ip_address_1>.9151 49878 0 49152 0 CLOSE_WAIT
<ip_address_1>.47937 <ip_address_1>.9151 49878 0 49152 0 CLOSE_WAIT

 

  • Soubor /etc/hosts v klientovi obsahuje:
::1 localhost
127.0.0.1 localhost localhost.localdomain

 

  • Potvrzeno s ipfstat -io Brána firewall (filtr IP) není spuštěna ani nakonfigurována.

 

Cause

Hostitel Solaris nemohl přiřadit a udržovat porty pomocí "connection ports: 0-0

 

Resolution

Aktualizujte porty připojení používané v klientovi.

  1. Přihlaste se ke klientovi jako uživatel root.

  2. Spusťte následující příkaz nsrports Příkaz k nastavení rozsahu portů připojení z výchozího (0-0) na starší rozsah portů (10001-30000):
    nsrports -C 10001-30000

  3. Ověřte nové nastavení portu příkazem nsrports bez dalších příznaků.

[root@lnx-client02]:~# nsrports
Service ports: 7937-9936
Connection ports: 10001-30000

 

Alternativní řešení: Zastavení démonů NetWorker na klientovi, ukončení všech zbývajících démonů pomocí příkazu kill a následné spuštění démonů umožní, aby zálohy nějakou dobu fungovaly.

 

Article Properties


Affected Product

NetWorker

Product

NetWorker

Last Published Date

23 Feb 2024

Version

5

Article Type

Solution