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NetWorker : Échec de la sauvegarde sur Solaris NetWorker Client avec le message « Impossible de lier le socket au port de connexion »

Summary: Ports de connexion : 10001-30000 permet aux processus de maintenir les connexions sur l’hôte Solaris lorsque les sauvegardes signalent le message « Cannot bind socket to connection port in configured port on system ». : Impossible d’attribuer l’adresse demandée. » ...

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Article Content


Symptoms

  • La sauvegarde planifiée de l’hôte Solaris signale occasionnellement les éléments suivants :
61320:savefs: Cannot bind socket to connection port in configured port range on system <Client_name>: Cannot assign requested address
61320:savefs: Cannot bind socket to connection port in configured port range on system <Client_name>: Cannot assign requested address
97512:savefs: Cannot access NetWorker server '<NetWorker_server_name>': Remote system error - Cannot assign requested address
savefs <Client_name>: failed.

 

  • Le fichier daemon.raw sur le client signale :
61320 1483533202 3 1 126 3 38646 0 <Client_name> nsrexecd SYSTEM error 79 Cannot bind socket to connection port in configured port range on system %s: %s 2 12 10 <Client_name> 24 31 Cannot assign requested address - Port is free

NetWorker : utilisation de nsr_render_log

 

  • La commande netstat sur le client a CLOSE_WAIT s pour 7937 et 7938.
root@<Client_Name> # netstat -an | grep -i 7938
<ip_address_1>.37938 <ip_address_1>.9151 49878 0 49152 0 CLOSE_WAIT
<ip_address_1>.47938 <ip_address_1>.9151 49877 0 49152 0 CLOSE_WAIT
<ip_address_1>.57938 <ip_address_1>.9151 49877 0 49152 0 CLOSE_WAIT
 
root@fmsprochk1 # netstat -an | grep -i 7937
<ip_address_1>.37937 <ip_address_1>.9151 49875 0 49152 0 CLOSE_WAIT
<ip_address_1>.57937 <ip_address_1>.9151 49878 0 49152 0 CLOSE_WAIT
<ip_address_1>.47937 <ip_address_1>.9151 49878 0 49152 0 CLOSE_WAIT

 

  • Le fichier /etc/hosts sur le client contient :
::1 localhost
127.0.0.1 localhost localhost.localdomain

 

  • Confirmé avec ipfstat -io que le pare-feu (filtre IP) n’est pas en cours d’exécution ni configuré.

 

Cause

L’hôte Solaris n’a pas pu attribuer et gérer les ports avec les « connection ports : 0-0

 

Resolution

Mettez à jour les ports de connexion utilisés sur le client.

  1. Connectez-vous au client en tant qu’utilisateur root.

  2. Exécutez la commande suivante : nsrports Commande pour définir la plage de ports de connexion de la valeur par défaut (0-0) à la plage de ports héritée (10001-30000) :
    nsrports -C 10001-30000

  3. Vérifiez le nouveau paramètre de port en exécutant nsrports sans balises supplémentaires.

[root@lnx-client02]:~# nsrports
Service ports: 7937-9936
Connection ports: 10001-30000

 

Solution de contournement : L’arrêt des processus NetWorker sur le client et l’utilisation de l’arrêt kill pour mettre fin aux processus restants, puis le démarrage des processus permettent aux sauvegardes de fonctionner pendant un certain temps.

 

Article Properties


Affected Product

NetWorker

Product

NetWorker

Last Published Date

23 Feb 2024

Version

5

Article Type

Solution