Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

NVP vProxy: Odstraňování problémů se snapshoty VMware během zálohování NetWorker.

Summary: Tento článek databáze znalostí slouží jako reference pro podporu NetWorker a správce týkající se záloh virtuálních počítačů, které se provádějí prostřednictvím zařízení NVP vProxy. Zálohování virtuálních počítačů se nezdaří a zobrazí se chyba související se snapshotem. ...

This article applies to   This article does not apply to 

Symptoms

  • Virtuální počítače VMware jsou chráněny prostřednictvím zařízení NetWorker VMware Protection (NVP) vProxy.
  • Zálohování se nezdaří a zobrazí se chyba související se snapshotem. Existuje několik variant chyb snapshotů, které se mohou zobrazit. téměř vše lze vyřešit pomocí následujícího článku databáze znalostí.

Protokoly:

Server NetWorker:

Protokol akce zálohování nebude poskytovat žádné komplexní podrobnosti o selhání zálohování virtuálního počítače a pouze oznámí, že akce selhala. Zobrazí se informace o selhání zálohování virtuálních počítačů. Zkontrolujte protokoly zásad na serveru NetWorker a bude existovat protokol relace obsahující název virtuálního počítače:

Linux: /nsr/logs/policy/POLICY-NAME/WORKFLOW-NAME/###-VM-NAME-DATE.log
Systému Windows: Poznámka: C:\Program Files\EMC NetWorker\nsr\policy\POLICY-NAME\WORKFLOW-NAME\####-VM-NAME-DATE.log

Poznámka: 
Tyto protokoly relace jsou stejné informace, které lze nalézt v protokolech vproxy zařízení vbackupd. Zkontrolujte, zda se nedaří vytvořit snapshot.
 

Zařízení vProxy:

Přejděte do zařízení vProxy používaného zálohováním virtuálního počítače pomocí účtu správce přes protokol SSH.

Po dokončení/selhání zálohování virtuálního počítače se protokol relace přesune do následujícího umístění:
/opt/emc/vproxy/runtime/logs/recycle/vbackupd/DATE/

Poznámka: Jedná se o stejné protokoly relace, které lze nalézt na serveru NetWorker, jak je uvedeno výše.

Systém vProxy obsahuje také protokol snapmngr, který naleznete v části:
Poznámka: /opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-snapmgr.log

Poznámka: Tento protokol obsahuje zprávy o vytváření, konsolidaci a smazání snapshotů.

Cause

Na začátku zálohování virtuálního počítače odešle zařízení vProxy požadavek na snapshot serveru vCenter. Za vytvoření a správu snapshotů zodpovídá server vCenter. v rámci systému VMware dochází k jakýmkoli zjištěným selháním a jsou nahlášena pouze zpět nástroji NetWorker z rozhraní VMware API.

Přehled snapshotů virtuálních počítačů naleznete v článku databáze znalostí VMware: https://kb.vmware.com/s/article/1015180  image.png

Resolution

Pokud snapshoty VMware selžou během zálohování virtuálního počítače, je třeba také zkontrolovat funkci snapshotu VMware z webového klienta vSphere. Tím se ověří, zda k problému dochází mimo pracovní postup zálohování NetWorker a v prostředí VMware.

Pokud je záloha virtuálního počítače standardní zálohou založenou na bitové kopii, není potřeba žádný vychytávkový snapshot. Pokud je virtuální počítač SQL, který provádí konzistentní zálohování aplikace MSVMAPPAGENT, je třeba provést vychytávaný snapshot.

Pokud je snapshot vytvořen úspěšně, zkonsolidujte virtuální počítač a odstraňte snapshot virtuálního počítače ze systému VMware vSphere.
image.png

Prostředí Storage vMotion lze také provést ve virtuálním počítači za účelem vyčištění souborů virtuálního počítače.

Jakékoli problémy zjištěné při vytváření, konsolidaci nebo odstranění snapshotu musí být vzneseny podpoře společnosti VMware. 

Nástroj ProxyHC lze také použít k provádění některých čištění potenciálních problémů se snapshotem/diskem, pokud jsou použity následující možnosti: Vyčištění

disku úkolů ./ProxyHCNVP-vProxy: Jak používat nástroj kontroly stavu ProxyHC v zařízení vProxy

Additional Information

Affected Products

NetWorker

Products

NetWorker Family, NetWorker Series
Article Properties
Article Number: 000201426
Article Type: Solution
Last Modified: 29 Feb 2024
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.