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Printer Spooler Error Troubleshooting and Solutions for Windows Users

Summary: Learn how to resolve print spooler errors in Windows. Learn to stop and start the print spooler and troubleshoot printer issues with these step-by-step guides.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Print spooler errors are present. Documents sent to the printer do not print and are stuck in the printer spooler.

Affected Operating Systems:

  • Windows 11
  • Windows 10
  • Windows 8.1
  • Windows 8
  • Windows 7

Cause

A problem with the print spooler can cause some printing and communication issues. Sometimes, restarting or clearing the print spooler may resolve these issues. The print spooler helps your Windows computer interact with the printer, and orders the print jobs in your queue.

Resolution

Table of Contents:

  1. How to Manually Stop and Start the Print Spooler
  2. How to Manually Delete Files from the Spool Folder
  3. How to Manually Delete a Printer from the Registry
  4. How to Resolve Printer Spooler Errors

How to Manually Stop and Start the Print Spooler

  1. Click the Start button and select Run. Type command (Figure 1) and then click OK to display the Command Prompt (Figure 2).

    Typing command in the run window

    Figure 1: Typing command in the Run window


    Command prompt

    Figure 2: Command Prompt

  2. In the Command Prompt, type net stop spooler and then press Enter to stop the Print Spooler.
  3. In the Command Prompt, type net start spooler and then press Enter to start the Print Spooler.

How to Manually Delete Files from the Spool Folder

If you have jobs that are stuck in the print queue that cannot be deleted, you might have to manually delete them.

  1. Stop the print spooler.
Note: For more information about how to stop the printer spooler, reference the How to Manually Stop and Start the Print Spooler section of this article.
  1. Browse to the C: drive and open it.
  2. Browse to WINDOWS and open it.
  3. Browse to SYSTEM32 and open it.
  4. Browse to SPOOL and select it.
  5. Browse to PRINTERS.
  6. Delete all the files located in this folder. For example, they may appear as FP00008 or FP00008.SHD.
  7. Start the Print Spooler.
Note: For more information about how to start the printer spooler, reference the How to Manually Stop and Start the Print Spooler section of this article.

How to Manually Delete a Printer from the Registry

It is also possible to delete printers from the computer's registry. If the printer cannot be deleted or removed, and restarting the print spooler has not cleared the issue, remove the printer manually from the registry.

Warning: Changing or deleting files from the registry may cause issues with your operating system, such as being unable to boot to Windows. Do NOT modify the registry unless you are comfortable doing so. If the registry becomes corrupted, you may have to reinstall the Windows operating system.
  1. Click the Start button and then click Run. Type command and then click OK to display the Command Prompt.
  2. Type regedit and then press Enter. This brings up the Registry Editor (Figure 3).

    Registry Editor

    Figure 3: Registry Editor

  3. In the Registry Editor, expand Computer.
  4. Expand the HKEY_CURRENT_USER folder (Figure 4).

    HKEY_CURRENT_USER folder

    Figure 4: HKEY_CURRENT_USER folder

  5. Expand the Printers folder.
  6. Double-click on the Connections folder (Figure 5).

    Connections folder

    Figure 5: Connections folder

  7. Only delete the printer queue and the printer (Figure 6). DO NOT DELETE ANYTHING ELSE.

    Printer queue and printer

    Figure 6: Printer queue and printer


How to Resolve Printer Spooler Errors

Windows 11 and Windows 10

  1. Type troubleshooting in the Windows search box.
  2. Click Troubleshooting Settings (Control Panel)
  3. Click Use a printer under Hardware and Sound.
  4. Click Advanced.
  5. Click Run as administrator. When asked, input your credentials or cancel if you do not know them.
  6. Click Next and follow the prompts.
Note: If the issue persists, you must uninstall and reinstall the latest printer drivers for your printer. For more information concerning Dell printers, see Dell Knowledge Base article Dell Printer Uninstalling, Downloading and Installing Printer Drivers, Software, Manuals, and Firmware. For non-Dell branded printers, see the printer's manufacturer’s website.

Windows 8.1 and Windows 8

  1. Press and hold the Windows key and then press the Q key on the keyboard.
  2. Type troubleshooting in the search box.
  3. Click Troubleshooting.
  4. Click Use a printer under Hardware and Sound.
  5. Click Advance.
  6. Click Run as administrator. When asked, input your credentials or cancel if you do not know them.
  7. Click Next and follow the prompts.
Note: If the issue persists, you must uninstall and reinstall the latest printer drivers for your printer. For more information concerning Dell printers, see Dell Knowledge Base article Dell Printer Uninstalling, Downloading and Installing Printer Drivers, Software, Manuals, and Firmware. For non-Dell branded printers, see the printer's manufacturer’s website.

Windows 7

  1. Click Start.
  2. In the Windows search box, type troubleshooting.
  3. Click Troubleshooting (it should be at the top of the list under Control Panel).
  4. Click Use a printer under Hardware and Sound.
  5. Click Advanced.
  6. Click Run as administrator. When asked, input your credentials or cancel if you do not know them.
  7. Click Next and follow the prompts.
Note: If the issue persists, you must uninstall and reinstall the latest printer drivers for your printer. For more information concerning Dell printers, see Dell Knowledge Base article Dell Printer Uninstalling, Downloading and Installing Printer Drivers, Software, Manuals, and Firmware. For non-Dell branded printers, see the printer's manufacturer’s website.

Affected Products

Printers & Accessories
Article Properties
Article Number: 000125904
Article Type: Solution
Last Modified: 25 jan 2024
Version:  7
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