Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products

Kennisgeving aan de klant van FluidFS: Hoe de reclaimer-service ruimte vrijmaakt op een NAS-pool

Summary: In deze klantmelding wordt uitgelegd hoe de reclaimer-service ruimte vrijmaakt op een NAS-groep.

This article applies to   This article does not apply to 

Symptoms

Wanneer een snapshot wordt verwijderd, wordt deze gescand om de blokken vrij te maken die het exclusieve eigendom was. Dit proces, ook wel reclaimer genoemd, wordt op de achtergrond uitgevoerd.
Hoe groter de snapshot, hoe langer deze bewerking duurt. Nadat het terugvorderingsproces is voltooid, komt de volledige vrijgekomen ruimte beschikbaar voor het volume.

 

Het moet worden uitgevoerd voordat blokken kunnen worden unmapped met behulp van scsi unmap (indien ingeschakeld) in de back-end SAN-volumes.

Reclaimer wordt in de wachtrij geplaatst om te worden uitgevoerd wanneer er data in de NAS-pool worden verwijderd, inclusief data die zijn verwijderd uit shares, NAS-volumes en het verwijderen van snapshots.

Cause

Bekende beperkingen en problemen

  • De reclaimer-service kan niet handmatig worden uitgevoerd of voor een langere periode worden gestopt. Zodra deze begint, moet de wachtrij worden voltooid voordat ruimte wordt vrijgegeven aan de NAS-pool. 
  • Het terugvorderen van snapshots is arbeidsintensief. Als er tegelijkertijd veel terugwinningsactiviteit plaatsvindt, kan dit prestatieproblemen in het cluster veroorzaken.  
    • Resource-intensieve terugwinningsbewerkingen kunnen zo veel invloed hebben op de prestaties dat dit van invloed kan zijn op de clienttoegang tot het cluster.
  • Er is een limiet voor het maken/verlopen van snapshots die per apparaat varieert op basis van de algehele systeembelasting. Dit kan rechtstreeks van invloed zijn op de functionaliteit van de reclaimer en het systeem.
    • Hoewel reclaimer is verbeterd in FluidFS firmware v6 voor het verwijderen van snapshots, is het mogelijk dat een overbelaste reclaimer-service de clienttoegang beïnvloedt. Deze gebeurtenissen worden gerapporteerd als "clients kunnen een lange periode van gedeeltelijke datatoegang ondervinden"
 

"Clients kunnen te maken krijgen met een lange periode van gedeeltelijke datatoegang"

Controleer of de prestatieproblemen zich voordoen rond de tijd dat sommige snapshots verlopen.

Er zijn meerdere typen snapshots:

  • Ad-hoc snapshots: snapshots die verlopen wanneer de beheerder ze verwijdert, of volgens de vervaltijd die door de beheerder is ingesteld. 
  • Geplande snapshots: snapshots die verlopen volgens de planningsdetails. De namen zijn gebaseerd op de planningsnaam.
  • NDMP-snapshots: snapshots die verlopen wanneer de NDMP-back-up is voltooid. De namen beginnen met ndmp.
  • Replicatiesnapshots: snapshots die verlopen nadat de volgende replicatie is voltooid. (Tijdens een replicatie zijn er twee snapshots, de vorige snapshot en de huidige snapshot.) Namen van replicatiesnapshots beginnen met rep.

Resolution

    Staggering snapshots-taken (standaardsnapshots, replicatie, NDMP)

    Als er tegelijkertijd veel snapshots verlopen, kan dit prestatieproblemen veroorzaken. 

    Minder, maar grotere, snapshots die tegelijkertijd verlopen, kunnen ook prestatieproblemen veroorzaken.

    Het wordt aanbevolen om snapshots per uur te spreiden over de tijd (stappen van 10 minuten) en dagelijkse snapshots over de dag te spreiden (bij voorkeur 's nachts). Wekelijkse snapshots verlopen bij voorkeur in het weekend.

    Affected Products

    Dell Compellent FS8600
    Article Properties
    Article Number: 000178040
    Article Type: Solution
    Last Modified: 19 Jul 2024
    Version:  4
    Find answers to your questions from other Dell users
    Support Services
    Check if your device is covered by Support Services.