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FluidFS-Kundenbenachrichtigung. Wie der Reclaimer-Service Speicherplatz auf einem NAS-Pool freigibt

Summary: In dieser Kundenbenachrichtigung wird erläutert, wie der Reclaimer-Service Speicherplatz auf einem NAS Pool freigibt.

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Symptoms

Wenn ein Snapshot gelöscht wird, wird er gescannt, um die Blöcke freizugeben, die er exklusiv besaß. Dieser Prozess, auch bekannt als Reclaimer, wird im Hintergrund durchgeführt.
Je größer der Snapshot, desto länger dauert dieser Vorgang. Nachdem der Reclaimer-Prozess abgeschlossen ist, wird der gesamte freigegebene Speicherplatz für das Volume verfügbar.

 

Er muss ausgeführt werden, bevor die Zuordnung von Blöcken mithilfe von scsi unmap (falls aktiviert) zu den Back-end-SAN-Volumes aufgehoben werden kann.

Reclaimer wird in die Warteschlange gestellt, um ausgeführt zu werden, wenn Daten im NAS-Pool gelöscht werden, einschließlich Daten aus Freigaben, NAS-Volumes und Snapshot-Löschungen.

Cause

Bekannte Einschränkungen und Probleme

  • Der Reclaimer-Service kann nicht manuell ausgeführt oder über einen längeren Zeitraum angehalten werden. Sobald er gestartet wurde, muss er seine Warteschlange beenden, bevor Speicherplatz für den NAS-Pool freigegeben wird. 
  • Die Rückgewinnung von Snapshots ist ressourcenintensiv. Wenn viele Rückgewinnungsaktivitäten gleichzeitig auftreten, kann dies zu Performanceproblemen im gesamten Cluster führen.  
    • Ressourcenintensive Rückgewinnungsvorgänge können sich so stark auf die Performance auswirken, dass der Client-Zugriff auf das Cluster beeinträchtigt wird.
  • Es gibt ein Limit für die Erstellung/den Ablauf von Snapshots, das je nach Appliance basierend auf der Gesamtsystemlast variiert. Dies kann sich direkt auf den Reclaimer und die Systemfunktionalität auswirken.
    • Obwohl der Reclaimer in der FluidFS-Firmware v6 für das Löschen von Snapshots verbessert wurde, ist es möglich, dass ein überlasteter Reclaimer-Service den Client-Zugriff beeinträchtigt. Diese Ereignisse werden als „Clients können über einen längeren Zeitraum nur teilweise auf Daten zugreifen“ gemeldet
 

„Clients können über einen längeren Zeitraum nur teilweise auf Daten zugreifen“

Prüfen Sie, ob die Performanceprobleme zu dem Zeitpunkt auftreten, zu dem einige Snapshots ablaufen.

Es gibt verschiedene Arten von Snapshots:

  • Ad-hoc-Snapshots: Snapshots, die ablaufen, wenn der Administrator sie löscht, oder gemäß der vom Administrator festgelegten Ablaufzeit. 
  • Geplante Snapshots: Snapshots, die gemäß den Planungsdetails ablaufen. Die Namen basieren auf dem Namen des Zeitplans.
  • NDMP-Snapshots: Snapshots, die ablaufen, wenn das NDMP-Backup abgeschlossen ist. Die Namen beginnen mit ndmp.
  • Replikations-Snapshots: Snapshots, die nach erfolgreichem Abschluss der nächsten Replikation ablaufen. (Während einer Replikation gibt es zwei Snapshots, den vorherigen Snapshot und den aktuellen Snapshot.) Namen von Replikations-Snapshots beginnen mit rep.

Resolution

    Staffelung von Snapshot-Aufgaben (Standard-Snapshots, Replikation, NDMP)

    Wenn viele Snapshots gleichzeitig ablaufen, kann dies zu Performanceproblemen führen. 

    Weniger, aber größere Snapshots, die gleichzeitig ablaufen, können ebenfalls zu Performanceproblemen führen.

    Es wird empfohlen, stündliche Snapshots über die Zeit (in Schritten von 10 Minuten) und tägliche Snapshots über den Tag zu staffeln (vorzugsweise mit Ablauf in der Nacht). Wöchentliche Snapshots sollten vorzugsweise am Wochenende ablaufen.

    Affected Products

    Dell Compellent FS8600
    Article Properties
    Article Number: 000178040
    Article Type: Solution
    Last Modified: 19 Jul 2024
    Version:  4
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