Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products

Scanning for Spyware, Malware and Adware (Windows Defender)

Summary: This article discusses some steps to help with spyware, malware, and adware detection and removal. It discusses the use of Windows Defender software that is included with Windows and runs automatically when your system is turned on. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms


Table of Contents:

  1. Scanning with Windows Defender
  2. Updating Windows Defender definitions
  3. Steps to take if you think you have been infected
  4. Tips on protecting against infection

1. Scanning with Windows Defender

NOTE: There are alternatives to Microsoft's Windows Defender on the market, but it is advisable to only have one anti-malware software application running at one time.

For information about other applications available, see Dell Knowledge Base article How to Identify and Repair Malware or Virus Infected Systems.

 

Windows 10

Windows Defender is integrated to Windows 10. No installation or subscription is required.

  1. In Cortana or the search box at the bottom of the Start menu, type Defender.

  2. From the results select Windows Defender Security Center. (shield icon)

  3. This opens the Windows Defender Security Center window.

  4. Under Scan History, you see the gray button for Quick Scan.

NOTE: Clicking Advanced Scan gives you three different types of scans:
  • Full Scan: Best run when the system is not planned to be in use, as this scans as many running files and programs as possible.
  • Custom Scan: This allows you to select which folders to scan.
  • Windows Defender Offline Scan: This option lets you restart Windows and runs a scan before the systems operating system has fully loaded. This is helpful to find and remove malware that is difficult to remove while Windows is up and running.

See the Microsoft Knowledge Base article for more information, including how to Schedule a scan in Windows Defender Anti virus This hyperlink is taking you to a website outside of Dell Technologies

 

Windows 8.1

  1. Move to the upper right and select Search type defender in the search box then select Windows Defender from the results.

  2. Select Scan options and select the scan option you want to run.

  3. Click Scan now.

 
NOTE: Full Scan is recommended for more detailed results, but it can take a long time to finish depending on several factors.

 

 

NOTE: You can schedule when Windows Defender scans your system, for more information about this see Microsoft Knowledge Base article Scheduling when Windows Defender scans your computer This hyperlink is taking you to a website outside of Dell Technologies

Back to Top


2. Updating Windows Defender definitions

Manual update:

  1. Open Windows Defender Security Center

  2. Click the arrow next to the help button (?) or the Shield icon from the left menu.

  3. Click Check for updates

For help on updating your Microsoft anti-malware and anti-spyware software, see the Microsoft Malware Protection Center This hyperlink is taking you to a website outside of Dell Technologies

If you receive an error message asking you to check for new definitions or advising that definition updates cannot be checked, downloaded, or installed. See Microsoft Knowledge Base article Security intelligence updates for Microsoft Defender Antivirus and other Microsoft antimalware  This hyperlink is taking you to a website outside of Dell Technologies

Back to Top


3. Steps to take if you think you have been infected

 

  1. Try to update the Microsoft Windows Defender definitions.

  2. Disable System Restore This hyperlink is taking you to a website outside of Dell Technologies

  3. Restart the computer and boot into Safe Mode This hyperlink is taking you to a website outside of Dell Technologies

  4. Scan for Malware with Windows Defender.

  5. Restart the computer and check for any symptoms of infection.

  6. If further scans show up clean, turn the system restore back on.

When the above is not possible, try running an Advanced Scan, preferably an Offline Scan of the system before running a Full Scan. (see the first section of this article)

Back to Top


4. Tips on protecting against infection


For information about applications and settings for Microsoft products that help protect against virus infection see Microsoft Knowledge Base article - How can I help protect my PC from viruses? This hyperlink is taking you to a website outside of Dell Technologies

Back to Top


Cause

No Cause Information is Available.

Resolution

SLN133937_en_US__13Secure  Get general information and guidance to secure your system or data on our Security and Antivirus page.
 

Affected Products

Inspiron, Latitude, Vostro, XPS, Legacy Laptop Models, Security, Software, Fixed Workstations
Article Properties
Article Number: 000138081
Article Type: Solution
Last Modified: 16 Feb 2024
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.