Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products

SourceOne Discovery Manager-exporter återupptar inte bearbetningen efter vänteläge och återgång

Summary: SourceOne Discovery Manager-exporter återupptar inte bearbetningen efter att skript för vänte- och återupptagning har körts.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

När SourceOne Discovery Manager-exporter som fortfarande tilldelas och körs har stängts av och återupptagits kan de lämnas i ett trasigt tillstånd. Exporter kan verka ha fastnat i körningen eller väntar, och jobbet som förväntas, bearbetas och objekt som inte har uppdaterats återspeglas i de faktiska värdena. Objekt som inte försökte exporteras kan också förbli i ett icke-misslyckat tillstånd så att de inte kan försöka igen. Detta noteras oftast när stora exporter utförs, tusentals till miljontals objekt, och endast om uppehållet inträffar när Discovery Manager fortfarande tilldelar artiklar för exportjobb.

Det förekommer inga fel eller någon annan indikation på ett problem som förväntar sig att exporterna inte visas i konsolen och att inga relaterade exportjobb körs i SourceOne-konsoljobbshanteringen.

En granskning av tabellen ExportActions för mer information visar objekt från exporten utan tilldelad delningsgrupp, vilket innebär att de inte är associerade med några exportjobb.

Cause

Det beror på att Discovery Manager-servertjänsten stoppas under vänteprocessen, vilket bryter den exportprocess som körs.  Det här undersöks för närvarande i SDR 63387.

Resolution

De enda metoderna för att lösa problemet är att begränsa exporter till så få objekt som möjligt så att de slutförs innan DM tillfälligt stängs av eller för att säkerställa att det inte finns några aktiva exporter när miljön inaktiveras.
Article Properties
Article Number: 000191871
Article Type: Solution
Last Modified: 16 Jan 2023
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.