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SourceOne Discovery Manager Exports do not resume processing after suspend and resume

Summary: SourceOne Discovery Manager Exports do not resume processing after suspend and resume scripts are run.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

After suspending and resuming SourceOne Discovery Manager exports that are still assigning and running might be left in a broken state. Exports may appear to be stuck running or waiting, and job expected, processed and failed items are not updated to reflect the actual values. Items that were not attempted to be exported may also remain in a non failed state so they cannot be retried. This is noted most often when performed large exports, hundreds of thousands to millions of items, and only if the suspend occurs when Discovery Manager is still assigning items to export jobs.

There are no errors or other indication of an issue expect the exports not appearing complete in the console and no related export jobs are running in the SourceOne console job management.

A review of the ExportActions table for details will show items from the export with no splitgroup assigned, which means they are not associated with any export job.

Cause

This is due to the Discovery Manager server service being stopped during the suspend process which breaks the running export process.  This is current being investigated in SDR 63387.

Resolution

The only methods to resolve this issue are to limit exports to as few items as possible so they complete before DM is suspended, or to ensure there are no running exports when the environment is suspended.
Article Properties
Article Number: 000191871
Article Type: Solution
Last Modified: 16 Jan 2023
Version:  3
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