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Microsoft Edge Runtime Error when Opening SupportAssist

Summary: Microsoft Edge WebView2 runtime error is displayed when opening SupportAssist for Home PCs v4.0 on computers that does not have the WebView2 runtime installed.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Affected Products:

  • SupportAssist for Home PCs

Affected Versions:

  • v4.0

When you open the SupportAssist for Home PCs v4.0 on computers that do not have the WebView2 runtime installed, Edge displays the following messages:

  • A suitable version of Microsoft Edge Webview2 Runtime was not detected. Download and install WebView2 Runtime.
  • Error occurred while initializing webview2: Object reference not set to an instance of an object.

Messages displayed when attempting to open SupportAssist without WebView2 runtime installed
Figure 1: (English Only) Messages displayed when attempting to open SupportAssist without the WebView2 runtime installed

Cause

Microsoft Edge WebView2 runtime is not installed or corrupted.

Resolution

  1. Open the control panel and verify that the Microsoft edge webview2 runtime is installed.

Microsoft Edge WebView2 Runtime listed under Programs and Features
Figure 2: (English Only) Microsoft Edge WebView2 Runtime listed under Programs and Features

  1. If not installed, then go to step 5.
  2. If installed, double-click on Microsoft Edge Webview2 Runtime and select repair option and let it complete.
  3. Now Open SupportAssist UI from the Start menu, the UI should open fine, or else proceed with the next step.
  4. Download and install the latest version of Microsoft Edge Webview2 Runtime This hyperlink is taking you to a website outside of Dell Technologies..
    1. After you open the above URL, you will find multiple Builds or versions available.
    2. Sort the latest available version using Last Updated.

Sort by Last Updated
Figure 3: (English Only) Sort by Last Updated

  1. To identify your System Type, go to search bar and type System Information.
  2. Reference to System Type for the bit version and use appropriate build from the list.

Reference System Type for bit version
Figure 4: (English Only) Reference System Type for bit version

Affected Products

SupportAssist for Home PCs
Article Properties
Article Number: 000221725
Article Type: Solution
Last Modified: 01 Feb 2024
Version:  1
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