Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
Some article numbers may have changed. If this isn't what you're looking for, try searching all articles. Search articles

Latitude Laptop Shows Red, Green, Blue (RGB) Screen(BIST RGB screen), Stops Responding, and then Displays a Black Screen

Summary: This article provides information about how to troubleshoot when your laptop displays a red, green, blue (RGB) screen and then stops responding with a black screen.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

A Latitude may display a red, green, blue (RGB) screen, and then stop responding with a black screen. The diagnostic LEDs show 3-Amber 6-White. The computer cannot be recovered by performing a hard restart. The BIOS version is 1.1.1.
 


Affected Products:

  • Latitude 5420
  • Latitude 7320
  • Latitude 7420
  • Latitude 7520
  • Latitude 9520

Cause

MBIST's code process triggers the recovery process.

Resolution

The BIOS must be updated to a newer version. Reference the following steps to update the BIOS to version 1.3.12 (or newer) and manually recover the BIOS.

Note: For more information about BIOS recovery, reference How to Recover the BIOS on a Dell Computer or Tablet.

To recover and update the BIOS:

  1. Press and hold the power button on the computer for 4 seconds until the computer shuts down.
  2. Download the latest BIOS (version 1.3.12 or newer) from https://www.dell.com/support.
  3. Rename the file to "BIOS_IMG.rcv" and copy it to a USB drive or SSD.
  4. Insert the USB disk or SSD into the computer.
  5. Press and hold the ESC and CTRL keys, then plug the AC adapter into the computer (Figure 1).
    image.png
    (Figure 1. Plug in the AC while pressing the ESC and CTRL keys)
  6. Select Recover the BIOS (using the currently-flashed BIOS) (Figure 2).
    image.png
    (Figure 2. Selecting Recover the BIOS)
  7. Press OK to start recovering the BIOS (Figure 3). This also updates the computer's BIOS version.
    image.png
    (Figure 3. Pressing OK to start recovering the BIOS)
  8. The computer boots into the operating system once the process is complete.

Affected Products

Latitude 7320, Latitude 7420, Latitude 7520, Latitude 9520, Latitude 5420
Article Properties
Article Number: 000185698
Article Type: Solution
Last Modified: 11 Feb 2022
Version:  10
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.