Passer au contenu principal
  • Passer des commandes rapidement et facilement
  • Afficher les commandes et suivre l’état de votre expédition
  • Créez et accédez à une liste de vos produits
  • Gérer vos sites, vos produits et vos contacts au niveau des produits Dell EMC à l’aide de la rubrique Gestion des informations de l’entreprise.

Data Domain. Слишком частое обновление Attr BTree вызывает критическую ошибку файловой системы

Résumé: Частое обновление Attr BTree может привести к ошибкам PANIC файловой системы, такие как «PANIC: ddr/dm/dmbt_iface.c: dmbt_find_intr_key_new: 10994: (i + 1) > = количество».

Cet article concerne   Cet article ne concerne pas 

Symptômes

Критическая ошибка файловой системы при следующих потоках PANIC (в разных версиях может отображаться другая версия):      
  PANIC : ddr/dm/dmbt_iface.c: dmbt_find_intr_key_new: 10994: (i + 1) >= count
Or
  PANIC: ddr/dm/dmbt_intern_fast.c: dmbt_bsearch_page: 157: Unsupported page type reported
Or
  PANIC: ddr/dm/dmbt_iface.c: dmbt_find_intr_key_new: 11664: (i + 1) >= count
Эта проблема наблюдается в нескольких выпусках DDOS.
  • Она была впервые выявлена в DDOS 6.1.1.5.
  • Со временем эта проблема также затрагивает версии DDOS, более ранние, чем 6.2.1.40 и 7.2.0.50.

Cause

Репликация запускает Attr BTree так часто, что файловая система в конечном итоге может вызвать критическую ошибку при доступе к метаданным атрибутов, связанным с файлами в MTree.

Аналогичная критическая ошибка также может возникнуть, если используется или часто используется функция отчетности о физической емкости (PCR).

Résolution

Если вы подозреваете, что в Data Domain имеется эта проблема, выполните следующие действия:      Со временем проблема возникает. Доступ к атрибуту или PCR BTree для данного MTree многократно предоставляется обычными системным рабочими нагрузками.
В затронутом выпуске DDOS проблема со временем ухудшается.
Производительность системы может быть затронута даже до появления PANIC файловой системы.
После того как из-за этой проблемы в файловой системе возникла проблема, в зависимости от того, где в BTree возникает проблема, в любое время могут возникать последующие PANIC файловой системы (даже назад к задней, поддержание файловой системы в состоянии down).

Основная проблема, вызываемая ухудшением атрибута или PCR BTree, устранена в следующих выпусках DDOS:
  • DDOS 6.2.1.40 или более поздней версии в DDOS 6.2.1.x
  • DDOS 7.2.0.50 или более поздней версии в DDOS 7.2.x
  • DDOS 7.3.0.10 или более поздней версии в DDOS 7.3.x
  • DDOS 7.4.0.0 и все более поздние выпуски
Модернизация до фиксированной версии не устраняет существующую деградацию затронутого атрибута или PCR BTree.
Это должно ухудшить ситуацию, но в некоторых случаях ее невозможно исключить, а замедление системы может произойти из-за ухудшения существующего BTree, а также возможно возникновение PANIC файловой системы.

Для устранения этой проблемы необходимо обратиться в службу технической поддержки Dell для выполнения команд низкого уровня (при необходимости простоя), чтобы атрибуты (PCR BTree) были удалены (со временем они автоматически создаются после повторного запуска процесса файловой системы). Поэтому рекомендуется обратиться в службу поддержки для устранения существующего повреждения BTree и немедленно выполнить обновление до исправленного выпуска.
См. Data Domain: Версии ПРОГРАММНОГО ОБЕСПЕЧЕНИЯ DD OS для получения рекомендаций по требуемой версии. Для просмотра статьи необходимо войти в службу поддержки Dell как зарегистрированный пользователь.

Produits concernés

Data Domain
Propriétés de l’article
Numéro d’article: 000079012
Type d’article: Solution
Dernière modification: 11 déc. 2023
Version:  18
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.
Propriétés de l’article
Numéro d’article: 000079012
Type d’article: Solution
Dernière modification: 11 déc. 2023
Version:  18
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.