Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

Nie można zmienić modułu TPM pomiędzy wersjami 1.2 i 2.0, ponieważ moduł ma przypisanego właściciela

Summary: W tym artykule opisano problem, w którym nie można skonfigurować modułu TPM, ponieważ jest on w stanie własności.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Nie można skonfigurować modułu TPM, ponieważ jest on już w stanie własności.

Cause

Po każdym ponownym uruchomieniu systemu Windows 10 z modułem TPM system Windows 10 automatycznie przejmie na własność moduł TPM, chyba że system Windows 10 zostanie wyraźnie poinstruowany, aby nie przejąć na własność.

Proces uaktualniania do wersji TPM 2.0 lub przywracania starszej wersji TPM 1.2 wymaga uwolnienia własności modułu przed dokonaniem zmiany.

Resolution

Niniejsze instrukcje uniemożliwią ponowne automatyczne przejęcie na własność modułu TPM w systemie Windows 10:
  1. Uruchom program PowerShell jako administrator: (Wpisz PowerShell w polu wyszukiwania, kliknij prawym przyciskiem myszy pozycję PowerShell w menu, a następnie kliknij polecenie Uruchom jako administrator. (patrz rys. 1).

    SLN302620_en_US__1Opening-PowerShell-with-admin
    Rysunek 1. Otwieranie programu PowerShell
  2. W programie PowerShell uruchom następujące polecenie: Disable-TpmAutoProvisioning ( Wyłącz TpmAutoProvisioning ), a następnie naciśnij klawisz Enter. (Patrz Rysunek 2).

    SLN302620_en_US__2Disable-TPM-autoprovisioning
    Rysunek 2. Wyłączanie automatycznego inicjowania obsługi modułu TPM w programie PowerShell.
  3. Jeśli zainstalowano rozwiązanie Dell Data Protection (DDP), konieczne będzie wykonanie następujących dodatkowych czynności:
    1. Otwórz aplikację pulpitu usług (wpisz services.msc w polu wyszukiwania i naciśnij klawisz Enter)
    2. Ustaw dla usługi DellMgmtAgent systemu Windows parametr Wyłączona
    3. Zatrzymaj usługę DellMgmtAgent windows
    4. Ustaw dla usługi DellMgmtLoader systemu Windows parametr Wyłączona
    5. Zatrzymaj usługę DellMgmtLoader dla systemu Windows
    6. Kontynuuj czyszczenie modułu TPM
  4. W polu wyszukiwania wpisz polecenie tpm.msc , a następnie naciśnij klawisz Enter , aby otworzyć konsolę zarządzania modułem TPM. (Patrz rys. 3).

    SLN302620_en_US__3Clear TPM
    Rysunek 3. Konsola zarządzania modułem TPM
  5. Wybierz opcję Czyszczenie modułu TPM.
  6. System zostanie uruchomiony ponownie, wyłączy się i włączy się ponownie.
  7. Nie należy wchodzić do systemu BIOS, należy ponownie zalogować się do systemu Windows.
  8. Uruchom narzędzie oprogramowania wewnętrznego modułu Dell TPM 1.2 lub narzędzie oprogramowania wewnętrznego modułu Dell TPM 2.0 z zasilaczem podłączonym do systemu.
  9. Jeśli zainstalowano rozwiązanie Dell Data Protection (DDP), konieczne będzie wykonanie następujących dodatkowych czynności:
    1. Ustaw dla usługi DellMgmtLoader systemu Windows parametr Automatycznie
    2. Uruchom usługę DellMgmtLoader systemu Windows
    3. Ustaw dla usługi DellMgmtAgent systemu Windows parametr Automatycznie
    4. Uruchom usługę DellMgmtAgent systemu Windows

Opcjonalnie

Za pomocą wiersza poleceń można uruchomić następujące polecenie, aby określić, czy moduł TPM jest własnością. (Naciśnij kombinację klawiszy CTRL + R, wpisz cmd, a następnie kliknij prawym przyciskiem myszy cmd.exe i uruchom jako administrator)

Wpisz: Wmic /namespace:\\root\CIMV2\Security\MicrosoftTpm path Win32_Tpm get /value , a następnie naciśnij klawisz Enter. (Patrz Rysunek 4).

SLN302620_en_US__4Command-line-TPM-status
Rysunek 4 — stan własności modułu TPM

Additional Information

Affected Products

Desktops & All-in-Ones, Laptops, Workstations
Article Properties
Article Number: 000139777
Article Type: Solution
Last Modified: 26 أغسطس 2024
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.