Symptoms
The impact of this issue is:
- The candidate file doesn't get uploaded during the 1st or 2nd attempt via GUI
- Primary SP reboot occurs.
- Unisphere GUI becomes non-responsive for 10-15 minutes or more
This issue was observed during the GUI upgrade on the array which is re-imaged to version 3.1.13.10192168.
Note: The presence of file /var/tmp/upgrade/upgrade.log with targeted version 3.1.13.10192168 indicates that the system was upgraded and not re-imaged.
Cause
Applicable Products:
VNXe1600 – SP3 (3.1.13.10192168) onwards
Impacted Areas:
Candidate file upload step from system upgrade process on HTML GUI.
Attached screenshot for reference "GUI_upgrade issue"
Resolution
Use below Uemcli commands to upgrade the system:
Steps involved in this process are
1. Healthcheck:
Uemcli /sys/general healthcheck
uemcli -d 10.0.0.1 -u joe -p MyPassword456! /sys/general healthcheck
Note: No issues were observed during this step in Unisphere GUI.
2. Upload File:
Uemcli -upload -f <file> upgrade
uemcli -d 10.0.0.1 -u joe -p MyPassword456! -upload -f “\\upgrade_image
\ VNXe-upc_BearcatRel_19_202109010410_upcBuilder-upgrade-3.0.0.2643839-3.1.16.10217556-GNOSIS_RETAIL.tgz.bin.gpg” upgrade
Note: Issue was observed during this step on some arrays.
3.Upgrade:
Create upgrade sessions:
Uemcli /sys/soft/upgrade create –candId <value>
uemcli -d 10.0.0.1 -u joe -p MyPassword456! /sys/soft/upgrade create –
candId CAND_1
Note: No issues were observed during this step in Unisphere GUI.
4.View Upgrade sessions:
Uemcli /sys/soft/upgrade show
uemcli -d 10.0.0.1 -u joe -p MyPassword456! /sys/soft/upgrade show
Note: No issues were observed during this step in Unisphere GUI.
Affected Products
VNXe1600, VNXe2 Series