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Dell FluidFS NAS Solutions Administrator's Guide

Troubleshooting Snapshots

Description

Taking and deleting snapshots fail.

Cause

Probable causes may be:

  • There are many client I/O requests waiting to be serviced, including a request to remove a large directory.
  • There are many snapshot creation/deletion requests being currently processed.
  • Another snapshot request for the volume is currently being executed.
  • The total number of snapshots reached the system limit.
  • Incorrect IP address was specified in the backup job.

Workaround

  • For a manual request failure, retry taking or deleting the snapshot after a minute or two.
  • If the request originated from the snapshot scheduler, wait another cycle or two. If the failure persists, try taking or deleting the snapshot manually on the same volume.
  • Check the dashboard if the system is under heavy workload. If the system is under a heavy workload, wait until the workload decreases and reissue the snapshot request.
  • Check the snapshot schedule. A very dense snapshot schedule has a negative impact on the overall performance of the system. The accumulated snapshot rate must not exceed 20 snapshots per hour per system.
  • Check the total number of snapshots in the system. If the number is in thousands, delete a few snapshots and retry.
  • Ensure the Client virtual IP address is specified in the backup job.

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