Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Dell FluidFS NAS Solutions Administrator's Guide

CIFS ACL Corruption

Description

CIFS ACL corruption.

Cause

  • ACLs were accidently changed by a user or script.
  • ACL is corrupted after an antivirus application accidently quarantined corresponding files.
  • ACL got corrupted after data recovery by backup application due to compatibility issues.
  • ACL got corrupted after migrating data from different location by using third party application. For example, RoboCopy.

Workaround

Check the current ACL setting in the Windows client. Redefine the ACLs for the files by using a Windows client the same way you initially defined it. Verify that you set the ACLs as the owner of the files, directories, and shares. In case you cannot redefine your ACLs since you currently do not have permissions, perform the following steps:

  1. Restore the files from snapshots or backup.
  2. In the case you have migrated the data from a different location using RoboCopy application, there is a good chance you can restore ACLs by copying only ACLs metadata, instead of re-copying the whole data.
  3. In case all file system ACLs are corrupted, you can restore all data from the NAS replication partner.

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\