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Dell FluidFS NAS Solutions Administrator's Guide

Cannot Mount NFS Export

Description

When attempting to mount an NFS export, the mount command fails due to various reasons such as:

  • Permission denied.
  • Appliance not responding due to port mapper failure - RPC timed out or input/output error.
  • Appliance not responding due to program not registered.
  • Access denied.
  • Not a directory.

Cause

  • The client connects using NFS/UDP and there is a firewall in the way.
  • The client is not in the export list, the appliance could not recognize the client system through NIS, or the appliance does not accept the identity you provided.
  • The NAS cluster solution is down or has internal file system problems.
  • The mount command got through to the port mapper, but the rpc.mountd NFS mount daemon was not registered.
  • Client system’s IP address, IP range, domain name or netgroup is not in the export list for the volume it is trying to mount from the NAS appliance.
  • Either the remote path or the local path is not a directory.
  • The client does not have root authority or is not a member of the system group. NFS mounts and unmounts are only allowed for root users and members of the system group.

Workaround

If the issue is due to NFS/UDP and firewall, check if the client mounts using UDP (this is usually the default) and there is a firewall in the path. If a firewall exists, add an appropriate exception to the firewall.

If the issue is due to permissions:

  • Verify the path you provided is correct.
  • Check that you are trying to mount as root.
  • Check that the system's IP address, IP range, domain name or netgroup is in the exports list.

If the appliance not responding due to a port mapper failure:

  • Check the NAS cluster solution status.
  • Check the network connection by trying to NFS mount from some other system.
  • Verify if other users experience the same problem.

If the appliance is not responding due to the program not registered, check if the port mapper on your client is up.

If the issue is due to access denied:

  • Get a list of the appliance exported file systems using the command:

    showmount -e <FluidFS hostname>

  • Check the system name or netgroup name is not in the user list for the file system.
  • Check the file systems related to the NFS through the NAS cluster solution user interface.

If the issue is due to the directory, check the spelling in your command and try to run the mount command on both directories.


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